Author Topic: Normal map errors when exported  (Read 2131 times)

Hey guys. First off I'd like to say I love Substance Painter, only just started using it but I'm blown away!

For my first SB project I'm trying to create a First Order helmet and it's been going great right up into trying to view my work in Marmoset.. I have no idea why but after I export everything, the normal map looks really sub-par when viewed in Marmoset. Pics incoming.

Low poly with normal applied within SP.


Normals viewed in Marmoset.


I was expecting a little loss in quality between the two programs but this just seems wrong. I'm really hoping it's a very simple setting I've missed or something? Any help would be greatly appreciated.

I'm exporting as png (16bit) using the Unreal 4 setup. My project config is set-up for DirectX.

Hey WH12,

make sure to Triangulate the object before baking the normal map. Also, Toolbag 2 can't read 16 bit PNGs, unfortunately. You would need to use TGA files instead.


Best Regards
Environment Artist - Twitter

Hey WH12,

make sure to Triangulate the object before baking the normal map. Also, Toolbag 2 can't read 16 bit PNGs, unfortunately. You would need to use TGA files instead.


Best Regards

Solved! You rock! Triangulating the mesh seems to have instantly fixed the bake issues, so glad it was something simple.

Thanks again :D

Just in case anyone was interested~

Here's my finished piece. First model textured using Substance Painter, very impressed!

https://www.artstation.com/artwork/aa9K2




Just in case anyone was interested~

Here's my finished piece. First model textured using Substance Painter, very impressed!

https://www.artstation.com/artwork/aa9K2





This is awesome! I love it : )

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja