Author Topic: Rust Effect not carrying over faces  (Read 1969 times)

Hello

Today is my first day using algorithmic products and I am currently testing to how if this is software that is worth investing in for my company. I have been looking up tutorials online and just playing around with it, but I have Had one issue that I haven't been able to fix yet. When I run the rust "substance" on my object you can see the "Joints". I have not seen online how to sort this issue out and not being a that much of a 3D modeler I am not sure if I am doing something wrong on that side of things eather. Attached is a screenshot of my problem.


Hard to tell. Can you show the UV layout of the mesh and point out if the geometry we see here has its uv island moved outside the 0-1 range?

Thanks I will add a UV pic bellow. Sorry, I am new, but what a a UV Range? and how do I find out?

Generators and other substance effect work in 2D Space. They are not aware of your UV islands and UV borders. That's why you get so many discontinuities. There is no real solutions here to make those effects work without making seams.

You can try some workaround :
- Redo you UVs (it's safe even if you already painted on the mesh, we will be able to reproject your brushs troke) to avoid the seams as possible
- Paint via brush strokes your rust in the 3D view, this way you will be able to cover the UV seams manually
- Use a fill layer set to the tri-planar projection mode, which should project over the mesh without making seams. You will then just have to mask out the area where you don't want the rust.

Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Thanks, for the help, How would I go about setting my fill layer too tri- Planar Projection?

Just like this :

Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Thanks very much for you help