Author Topic: App won't open on Mac  (Read 13682 times)

Hello,

Substance Designer 5 crashing on startup on my Mac Pro too, here is the url to the log of the crash, in case it can help :

http://pastie.org/10019684

Having a partition with Mac OS X 10.6.8 on my machine, I've made a try, and SD5 crashes there too. Here is the log :

http://pastie.org/10019731

I see on this log that libc++.1.dylib should be loaded, but, I've checked, and I can't find it on my 10.6.8 partition :

ls /Volumes/Yosemite/usr/lib/libc
libc.dylib              libcrypto.0.9.dylib     libcupsmime.1.dylib
libcblas.dylib          libcrypto.dylib         libcupsmime.dylib
libcharset.1.0.0.dylib  libcups.2.dylib         libcupsppdc.1.dylib
libcharset.1.dylib      libcups.dylib           libcupsppdc.dylib
libcharset.dylib        libcupscgi.1.dylib      libcurl.2.dylib
libclapack.dylib        libcupscgi.dylib        libcurl.3.dylib
libcom_err.dylib        libcupsdriver.1.dylib   libcurl.4.dylib
libcpp_kext.a           libcupsdriver.dylib     libcurl.dylib
libcrypto.0.9.7.dylib   libcupsimage.2.dylib    libcurses.dylib
libcrypto.0.9.8.dylib   libcupsimage.dylib

Last Edit: March 12, 2015, 12:32:08 am

Hello,

Substance Designer 5 crashing on startup on my Mac Pro too, here is the url to the log of the crash, in case it can help :

http://pastie.org/10019684

Having a partition with Mac OS X 10.6.8 on my machine, I've made a try, and SD5 crashes there too. Here is the log :

http://pastie.org/10019731

I see on this log that libc++.1.dylib should be loaded, but, I've checked, and I can't find it on my 10.6.8 partition :

ls /Volumes/Yosemite/usr/lib/libc
libc.dylib              libcrypto.0.9.dylib     libcupsmime.1.dylib
libcblas.dylib          libcrypto.dylib         libcupsmime.dylib
libcharset.1.0.0.dylib  libcups.2.dylib         libcupsppdc.1.dylib
libcharset.1.dylib      libcups.dylib           libcupsppdc.dylib
libcharset.dylib        libcupscgi.1.dylib      libcurl.2.dylib
libclapack.dylib        libcupscgi.dylib        libcurl.3.dylib
libcom_err.dylib        libcupsdriver.1.dylib   libcurl.4.dylib
libcpp_kext.a           libcupsdriver.dylib     libcurl.dylib
libcrypto.0.9.7.dylib   libcupsimage.2.dylib    libcurses.dylib
libcrypto.0.9.8.dylib   libcupsimage.dylib

Hi,

Substance Designer 5 is not compatible with 10.6. You need 10.7 minimum in order to use it.

Cheers,
Nicolas
Head of Product Management

Anyway, as a conclusion to this problem, we decided to take more users in our beta program, hoping that this will help to catch those problems in advance.
Cheers,
Nicolas

Hopefully you will keep one machine running Mavericks in future

substance_designer_5_0_2_build_15483.dmg works fine now


Hi,

Substance Designer 5 is not compatible with 10.6. You need 10.7 minimum in order to use it.

Cheers,
Nicolas

Yes, I've just seen that today. Sorry for the noise. It doesn't change that it crashes on my main partition which is under Yosemite, as you can see in the first log I have posted.  I see above that there is a 15483 build available. Trial version is only 15447. Could you put the 15483 version as trial version too, please ?
Last Edit: March 12, 2015, 04:19:26 pm

That version 15483 was just a quick unofficial build we put online so that users could check and confirm that we had indeed fixed the bug, since we can't reproduce it in-house. A proper official 5.0.2 version with that bug fixed (and a couple others) will be released in a few days.

Just thought I would mention that the 15483 build runs as fast as v4 on my Mac. Which is great considering the other v5 builds run ridiculously slow and had my fan kicking in every few seconds.
Looking forward to the official fix release. :)

That version 15483 was just a quick unofficial build we put online so that users could check and confirm that we had indeed fixed the bug, since we can't reproduce it in-house. A proper official 5.0.2 version with that bug fixed (and a couple others) will be released in a few days.

Thank you for your answer. In fact I'm interested by the steam version which is on discount actually, but I won't buy it if I'm not sure that SD5 works on my computer. Is there a way to get this new version sooner ?

Hopefully you will keep one machine running Mavericks in future

Actually a part of our team is still using Mavericks, as Yosemite is still way too buggy :)
As I mentioned earlier, the problems were not related to the OS version.

Cheers,
Nico
Head of Product Management

YES!!! The beta 5.0.2 works here, too :)

Seems to work, so please upload an official version asap !!!
Would like to use SD 5 on my mac, finally...

Cheers

gfx


5.02 worked initially, but now I've found a bug whereby trying to change the engine causes a crash. I need to change from SSE2 to OpenGL because of a different bug that causes the edge detect node to not work properly. ( listed here: https://forum.allegorithmic.com/index.php?topic=4169.msg19702#msg19702)

Hey gfx,

this is a known issue, both of it.
Internally there is a dirty fix for the Edge Detect already, the OpenGL fix could take a bit more time... Please be patient in the meantime.


Best Regards
Environment Artist - Twitter

5.02 worked initially, but now I've found a bug whereby trying to change the engine causes a crash. I need to change from SSE2 to OpenGL because of a different bug that causes the edge detect node to not work properly. ( listed here: https://forum.allegorithmic.com/index.php?topic=4169.msg19702#msg19702)

I have sort of the same problem. I have a hackintosh with a GTX 780ti that edge detect does not work in SS2 as stated but when I change to OpenGL engine I only see dots and noise. It does not work properly with Nvidia Web Driver 334.01.03f02 & Mavericks 10.9.5

In the other hand it does work properly in OpenGL in a Macbook Pro with Nvidia GT 650M (but I don't use it as main machine so ... )

Hope you fix son the cpu edge detect ... I don't mind to be it slow as long as it works ;)

Regards,
@No_Collision
Astrophotography, Landscapes and 3D Computer Graphics.
www.nocollision.com