Author Topic: PBR Spec Gloss Shader with normal_texture compiled  (Read 5692 times)

[GenericMaterial] The uniform 'normal_texture' doesn't exist in the compiled shader.
[GenericMaterial] The uniform 'normal_texture_is_set' doesn't exist in the compiled shader.

I'm getting these errors with the latest 1.2 version. I'm assuming this is because the shader I have does not have the recently added normal map channel compiled into the shader. Is there any way I can get an updated PBRSpecGloss.glsl shader from you. I started using the Spec gloss workflow and it's a bit late to swap to metal gloss but I'd still like to take advantage of the latest normal map channel added in 1.2.


Thanks!


Bump.

Posted a week ago and still haven't gotten a response.

Sorry for the late answer! We are updating our shader libraries for 1.3 so that outdated shaders will still work with more recent versions of Painter. We will also provide an updated SpecGloss shader at that time (next week).

Sounds Great! I'll see you guys at GDC! I'll be at the Crytek booth with Entrada Interactive. Can't wait to stop by and shake your hands! Excellent job with painter keep up the great work guys! Hopefully I can buy someone a beer to say thanks  8)

Hey Jeremy just checking on the status of the updated SpecGloss shader, if you had any updates on that I would greatly appreciate it.

Met you guys at GDC talked quite a bit with Fabrice at the booth. Great bunch of guys and you had an answer for every question. Got myself a sweet substance painter shirt also I'll be rocking that for a long time!

I have a few projects that were started with the SpecGloss Shader provided by allegorithmic and those projects no longer show any info I painted because the shader does not work at all with the new 1.3 version.

Shows up as pink.

Is there a way to convert these projects?

You just need a new shader, the content of the project is not lost (you can still export if you need to).
I think Jeremie is still working on converting the Spec/Gloss shader.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

Excellent thank you. Any word on an ETA? The conversion to spec gloss isn't 1:1 with CryEngine so spec gloss was pretty integral to my workflow after it was released by you guys. I also have quite a few projects started using the specgloss shader and I would hate to have to collapse them down to a single texture. Just to continue using painter.

1.3 is an awesome update triplanar and the integrated bakers are so handy! Super fast baking also! Great job on the update. It's amazing how fast you guys are adding features and making this app "THE painting app".

Here's to hoping for an updated specgloss shader soon. I'm kinda stuck on quite a few projects until this issue is resolved as well as a few other members on my team who found we could get perfect results using the specgloss shader for CE.

Here is an updated version of the shader for 1.3.

Awesome! You guys rock. Thanks!

[GenericMaterial] FS compile log:
[GenericMaterial] ------------------
[GenericMaterial] 0(308) : error C1038: declaration of "height_force" conflicts with previous declaration at 0(133)
[GenericMaterial] 0(483) : error C1060: incompatible types in initialization
[GenericMaterial] 0(483) : error C1056: invalid initialization

Getting that error

Any updates? This shader does not work and I just get a pink model and errors in the log.

I confirm,

the update SpecGloss Shader doesn't work unfortunately .
it's pink.

error: C1038
error: C1060
error: C1056

:(

That's good. Hopefully this will get fixed soon. I really don't want to collapse down a whole project I'd been working on for a month just to continue working.

This shader works for me in 1.3.2. Your error looks weird since I don't declare this height_force anywhere in the shader I posted. Make sure you don't have duplicates in your libraries.

I attached a new version with a minor warning fix.