Author Topic: Substance Painter Nvidia Driver outdated, but it isn't  (Read 691 times)

Hello,

I am having a problem where substance painter is telling me that I have an oudated driver, but I don't. I even installed the studio and game driver to see if there was any difference. It is workable, but I think it is slower (might be me overthinking it).

I sent a logfile from the version before the last, but it happens the same thing for the newest version.

Thank you in advance, and I apreciate the urge to solve this...

I had this same issue yesterday. But today it wouldn't even start. I uninstalled and reinstalled and even though it says it's installed, it still won't start and there's no shortcut on my desktop. If I close Substance Launcher and reopen, it shows that I have to install again.

You are definitely correct it is slower than it was yesterday before I updated to the new Studio drivers. I too am getting this error. I'll attach a couple of pictures and the log ^-^ Hopefully it's just a temporary thing because it's new, thanks in advance. :)
Last Edit: June 24, 2021, 02:14:24 pm

Indeed it is a bug.

so you did  update your Nvidia drivers and got a message that the driver is outdated, so you need to ignore the message and press continue.

Hi,
The issue mentioned above is a bug in our driver detection. We are currently looking into the matter; in the meantime, it shouldn't affect anything: click on "don't show this popup again" then on "continue anyway".
I hope this helps!
Regards,
Geoffroy SC

Thank you guys for your feedback. However, the error is causing other problems with use of the program. I can use it for around 20 minutes and then it will freeze and my graphic driver crashes, which then crashes the software and I have to restart my PC. I have been using 3DS Max, vRay etc fine even with rendering so I know the issue is one that exists within the new Substance itself. That only started happening with this error this morning.

If I click on the red GPU error it crashes my graphic driver instantly and I need to also restart my PC.
Last Edit: June 24, 2021, 06:19:01 pm

Hi,
Would you be able to share a log and, even better, send a crash report?
Thank you
Kind regards,
Geoffroy SC

Hey Geoffroy thanks for your reply. I have been unable to replicate the crash since I posted this. I changed my PCIE for the GPU in BIOS from Gen 4 to Gen 3 and the problem has stopped. The performance on the Adobe suite has improved in general. Thank you for your help.

With the new version of SP i am getting this message when I open the application.  I have downloaded the very latest drivers for my graphics card and still get the same message with respect to the GTX1080.  Not sure what the other log reports are indicating either. Any assistance would be appreciated.   The log readout below:-

[Resources List Model] Icons memory budget set to 100MB.
[Python] failed to load send_to_dn plugin

[Python] Traceback (most recent call last):

[Python]   File "C:/Program Files/Allegorithmic/Substance Painter/resources/python/modules\substance_painter_plugins.py", line 150, in _is_plugin_discarded
    return module.discard_plugin()

[Python]   File "C:/Program Files/Allegorithmic/Substance Painter/resources/python\plugins\send_to_dn\__init__.py", line 115, in discard_plugin
    send_to_dn_feature = _substance_painter.feature.RunTimeFeature.SendToDn

[Python] AttributeError: type object '_substance_painter.feature.RunTimeFeature' has no attribute 'SendToDn'

[Plugin - resources-updater] No project open, resources updater discarded
[GPUIssuesCheck] Installed driver for graphics adapter 'NVIDIA GeForce GTX 1080' is outdated.
You should update them for a better experience (http://www.geforce.com/drivers).
The currently installed version is 30.0.14.7111.
The recommended minimum version is 26.21.14.4250 (442.50 WHQL).

Hi,
The previous answer is was already a fix to the issue :

Quote
The issue mentioned above is a bug in our driver detection. We are currently looking into the matter; in the meantime, it shouldn't affect anything: click on "don't show this popup again" then on "continue anyway".
I hope this helps!
Regards,
Geoffroy SC
Modify message

The previous answer is was already a fix to the issue :
My fault, sorry for the confusion :) This was a separate thread which I have merged with this one since they were about the same topic.