Author Topic: Clone tool works only on single channel  (Read 893 times)

Hi there, normaly i not write for help but I have enough of that fight.
My problem is, clone tool works only on base color channel when all other are ignored.
Lower is vid as proof that everything seems to be setup correctly
- passthrough on all channels
- clone tool
- paint layer.


according to grzegorz, it suppose to work (and was working because I remove seams before)
https://youtu.be/U3AVpCA-wMo?t=1202

Make a new Paint Layer above the Fill Layer, set all the channels to Passthrough and it will work.
I teach people how to use Substance Painter. :)

Good idea but I checked it before post that help request.

Just in case, video proof  - thanks for spending your time trying help me. So if Grzegorz was able to make it and Im not, its mean we have bug here.

So you're saying it doesn't work regardless? You're not adding it the correct way I'm referring to. Do this:



Not sure why you're making a fill layer and adding a paint to it as opposed to just making the paint layer on its own...

Can you provide the .SPP file in which you're using it on and I'll test it on my end. I'm not aware of any bug, I use this feature regularly.

Also the way I teach is like I shown above, and even the official documentation suggests using a Paint Layer.

https://docs.substance3d.com/spdoc/clone-tool-143720522.html

Make sure this method works as it is what I use 100% of the time, and I don't use fills with paint layers under them for the clone tool.
Last Edit: May 19, 2021, 02:38:48 am
I teach people how to use Substance Painter. :)

well, I normally work like grzegorz so to fill layer I add paint layer (not above as you suggest) but I test all those setups (two fill layers, paint layer added, paint layer above) - any of those works on complex scenes in past. But no matter how, its still nothing. I attach that spp file :) and video as proof what I see on my end.
https://drive.google.com/file/d/1GRjqMKSpGxq0Hpg7_C8T_pKaQkTpIgd1/view?usp=sharing


I think I found problem. Paint layer contain option to be painted on various channels, apparently default in my case was to only work on color (now I know where to look).
Q: why by default that is setup only for color channel, not for all of them? - feedback to make it by default on all channels.

I think its single time thing that everybody need find to know later. I suggest to make small update to documentation
"A smarter way to use the Clone tool is to create a painting layer and set the blending mode of all the channels to "Pass through" - and add info "ensure that paint layer is setup on all channels."

But confirm on your end that was a issue as well - I work atm on 11 variation of project with plane from blender.

Well use whatever method works for you then. Yes, of course you need all those channels enabled, otherwise how would it work?
I teach people how to use Substance Painter. :)

Well, didn't know its up there - my mistake. Anyway, thanks for help me out :) learned couple other things as well during checking what going one.