Author Topic: Unity 2021 & Substance in Unity 2.5.4 error  (Read 309 times)

I get the following two errors when trying to import Substance for Unity 2.5.4 into Unity 2021.1.4 - Am I missing something? All I did was download and import the package.

Unloading broken assembly Assets/Allegorithmic/Plugins/Substance/Substance Engine/Editor/Substance.Editor.dll, this assembly can cause crashes in the runtime

TypeLoadException: Could not resolve type with token 01000051 (from typeref, class/assembly UnityEditor.Experimental.AssetImporters.ScriptedImporter, UnityEditor, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null)
Substance.Editor.SubstanceMain.Get () (at <2e38deb2a9a94c94ae9500ff9ee4ea05>:0)
Substance.Editor.EntryPoint.PingSingleton () (at <2e38deb2a9a94c94ae9500ff9ee4ea05>:0)
Substance.Editor.EntryPoint.AfterAssemblyReload () (at <2e38deb2a9a94c94ae9500ff9ee4ea05>:0)
UnityEditor.AssemblyReloadEvents.OnAfterAssemblyReload () (at <cbc56ce48ec645d2beabdfed6b9ae8ee>:0)

Hello @jaimi
When you install Substance plugin 2.5.4 on 2021.1.4 you get a dialog box asking your consent to update some API's. Please answer yes to this dialog box and you will not get this error.
Plugin 2.5.4 is not designed for this version of Unity, we are in process of releasing a new version of Substance Plugin.

Thx,