Author Topic: Object Deformation  (Read 710 times)

When I import my model to Substance Painter only grip part of my pistol get deformation. I bake my mesh with other software with no problem, but in Substance Painter my model gets weird.

If you're importing your mesh with n-gons just make sure you convert it to tris prior. Painter doesn't do well with n-gons during the conversion process.
I teach people how to use Substance Painter. :)

I trianglated my model as like other parts. But deformation be only grip part

So how does the grip look in other applications? It is hard to assist without actually seeing a mesh and what your expectation is. This could be a smoothing group issue.
I teach people how to use Substance Painter. :)

Model created in Autodesk Maya 2020. And all Hard and soft edges are correct.
https://imgur.com/hJvgRY5 (wireframe)
https://imgur.com/23kdgKt (low poly)
https://imgur.com/JtG4eCd (low poly baked)

I would need more details.

So are you getting problems with the mesh on import (not yet baking) in Painter? Or is the issue when you take the baked maps from toolbag to Painter?

Can you share the mesh file?
I teach people how to use Substance Painter. :)

Yes I'm getting problem with the mesh on import (not yet baking) in Painter. But I tried to take baked maps from toolbag to painter.. Same result.
https://www.dropbox.com/s/luoa0u4d175zjco/LOW%20BIG.fbx?dl=0

Yes I'm getting problem with the mesh on import (not yet baking) in Painter. But I tried to take baked maps from toolbag to painter.. Same result.
https://www.dropbox.com/s/luoa0u4d175zjco/LOW%20BIG.fbx?dl=0

I'll look at the mesh, however you want to make sure if you're baking in Toolbag that you use mikkt and not marmoset otherwise it wont look correct in Painter.
I teach people how to use Substance Painter. :)

Alright, so when you have something going from Maya to Painter like this it will not retain your hard/soft edges in the same way if something with the mesh isn't clean.

For example in Maya:



Then Painter:



This is actually very common if the mesh isn't clean. I don't have the time to go through the mesh to find which parts are causing the issue but run it through a cleaner. If it comes out fine you'll see it like this in Painter:



Stray vertices, and non manifold geometry, double edges, ect... will cause this.
I teach people how to use Substance Painter. :)

Thanks for solution. But last question. With which parameters did you cleanup? I clean up but same result.