Author Topic: Urgent- gltf exports 100x the regular size  (Read 1252 times)

My mesh is 22cm high in Maya. After I export the gltf the mesh is 100x larger in size at 2200cm.  Can anyone advise what to do to keep my 1:1 mesh ratio?   I couldn't find anything in the settings to adjust that.

Still cant seem to find a solution to this. I bet it's something super easy, that just doesn't cross my mind, but for now I'm stuck.  Anyone knows why my .gltf mesh increases in size upon export ?

1 cm = 0.01 metre and when you export out you should set your scale value to 0.01 in the exporter as I believe it exports based on metres...?



Give it a try. I exported out an FBX using cm with scale of 1, then GLTF with a scale of 0.01 and they both matched in another program when importing them side by side.
I teach people how to use Substance Painter. :)

Thanks CAGameDEV !

1. first of all what is that specific exporter are you using for Maya to gltf? I'm currently using the Babylon plugin. I'd like to try the plugin shown in your screenshot as well. let me know where to find it.

2. my workflow is  maya-> fbx -> SP -> gLTF/Glb

Below you will see screenshots of the workflow and the issue. 
My Maya settings are in Cm.   I this example I have a 2 cm sphere I'm exporting as a Fbx with correct scale.  That same Fbx was imported untextured in Unity and it's true to size (pictured next to the head model)
The same Fbx sphere was imported in Substance painter , was textures and exported as gLTF/Glb.  The giant purple ball is what was exported. It aslo flips the Z axis upon export. It's facing +Z when its exported in -Z.
I can't understand why this size increase and axis flip and unable to export gltf models true to size.
All my models end up Gulliver in the King of Lilliput. Joke aside, I need to deliver these models and I don't know where the issue is.
Thanks for any help/insight you might be able to provide.





Last Edit: November 22, 2020, 06:24:58 pm

still hoping for an answer.

can anyone help me with an answer?  Im still experiencing this size glb issue

You either want to set your working units in Maya as meters, or export out the FBX in meters- or to be safe, do both. The GLTF standard unit is in meters and will read any dimension you give it in meters, regardless of what units you used in the modeling program. The FBX export option is only really there to do conversions for you on export.