Author Topic: An error occurs when building with VS2017  (Read 696 times)

Hi.

I have a question about Substance in Unreal Engine.
I'm using a custom UE 4.26.1, so I needed to build it.

When I built it with VS2017, the following error occurred.
1> substancelink_framework.lib (export.obj): error LNK2001: unresolved external symbol __CxxFrameHandler4
1> substancelink_framework.lib (core.obj): error LNK2001: unresolved external symbol __CxxFrameHandler4
1> substancelink_framework.lib (system.obj): error LNK2001: unresolved external symbol __CxxFrameHandler4
1> substancelink_framework.lib (callbacks.obj): error LNK2001: unresolved external symbol __CxxFrameHandler4
1> Engine \ Plugins \ Marketplace \ Substance \ Binaries \ Win64 \ UE4Editor-SubstanceLink.dll: fatal error LNK1120: 1 unresolved externals

When I built it with VS2019, the build was successful.
I think Substance/Libs etc. are built with VS2019.
I would like to operate with VS2017. Is there any other solution or provision of VS2017 version?

Thanks for watching.

Hi.

I have a question about Substance in Unreal Engine.
I'm using a custom UE 4.26.1, so I needed to build it.

When I built it with VS2017, the following error occurred.
1> substancelink_framework.lib (export.obj): error LNK2001: unresolved external symbol __CxxFrameHandler4
1> substancelink_framework.lib (core.obj): error LNK2001: unresolved external symbol __CxxFrameHandler4
1> substancelink_framework.lib (system.obj): error LNK2001: unresolved external symbol __CxxFrameHandler4
1> substancelink_framework.lib (callbacks.obj): error LNK2001: unresolved external symbol __CxxFrameHandler4
1> Engine \ Plugins \ Marketplace \ Substance \ Binaries \ Win64 \ UE4Editor-SubstanceLink.dll: fatal error LNK1120: 1 unresolved externals

When I built it with VS2019, the build was successful.
I think Substance/Libs etc. are built with VS2019.
I would like to operate with VS2017. Is there any other solution or provision of VS2017 version?

Thanks for watching.


Hello @spdev
I talked to one of our developers and out 2.26.1 plugin is compatible with current marketplace version which is VS2019. We will look into _possibility_ of making the next release of the plugin to be compatible with 2017 but, will not commit to it.
Thx,

Thank you for your reply.

Even if it's not a marketplace.
There is no problem uploading to the bulletin board.
Please consider it.

Thank you.