Author Topic: cannot login to substance source  (Read 1845 times)

I click on login button, write email and password, click login, dialog window closes and nothing happens, login button remains the same on site
but looks like i can login in other services with this account just fine


Do you use a double authent system from your own company to log in, or do you have a personnal account?
Which browser do you use, and on which OS? Have you tried several browsers?

I'm going to need you help to let us find the issue, as on my side I can not reproduce it:

We are trying to find out why you encounter this issue, and will need help from you to help with troubleshooting. Sorry about that!

-   First, we will need you to go on Substance Source, open the dev console and ask to preserve the logs (see screenshot attached at the end of the post)
-   After that, we will ask you to try to log again: after you have logged in and have been logged out automatically, an error should be written in the console.
Could you please let us know what this error is?

Then, we will need you to go to and to log in there if it is not the case already. There, you will paste this in the dev console : adobeIMS.getUserProfile().account_type
Could you please let us know what it returns? It should read something like "type 1" or 2 or 3 etc.

That will help us understand why you are encountering this issue, and fix the problem asap.
Thanks a lot for your help!

PO @ Allegorithmic

I have a personal account. Just checked and I can log in with Mozilla, though I would like to stick with my preferable Chrome.
I use Windows 10, tried to log in on my android phone and problem is the same
here is the log:

On a have type1 account, but i registered my substance and adobe accounts before adobe acquisition and im not sure accounts merged or something

Thank you

Hi Chybsik,

On Chrome do you have browser add ons that could maybe affect the login?

On our side we tried to reproduce and the only way we had the same error was when there was a error/typo in the email or password for the substance account.

Your issue made us realize that it was not displayed in the UI when there was a wrong email/password combo and that the login popup just closed, which is not great and which we will fix soon.

So could you maybe try to re-type from scratch the email and password combo on Source? I know you mentionned that you can login in other services fine with this account but we never know, trying again could maybe be the solution...
Last Edit: March 03, 2021, 02:28:23 pm
PO @ Allegorithmic

that worked, guess it really was  just a typo  😅
thank you