Author Topic: Experiencing significant proformance drop in Susbtance Designer 2021  (Read 1049 times)

I recently update my substance designer from 10.1 to 2021 steam version, I notice the new version of substance designer became very slow, it struggles to do the basic thing. I tried to reinstall, and change setting in the NVIDIA control panel, update Nvidia drivers. but still couldn't solve the issue, could you please help me?

here is some more information that might help.
  • When I open SD 10.1 and do nothing (not even open project), the CPU usage is around 15%, but when I open SD 2021, the CPU usage is 0%.
  • I'm running SD on a laptop, i7-9750H CPU @ 2.60GHZ, 32GB, RTX 2060 mobile
  • I experienced the same problem in SD 2020, so I suspect it might have something to do with the new Substance Engine V8
  • there are a lot of thumbnails in the library that are missing in my SD 2021.
Last Edit: February 21, 2021, 02:27:43 am

Hello @Yi Sun,

Thank you for reaching out to us! I really appreciate the clear GIFs and detailed report, these are very helpful for investigating the problem.

I cannot reproduce this behaviour in my installation of version 2021.1.1 (11.1.1). Please share the following additional details:
  • In the General section of the Preferences window, what are the values for the Image cache and Job scheduler settings
  • Set these values to Custom mode, and input higher values based on your current system capabilities, then restart Substance Designer and try to reproduce the issue. Does it still occur?
  • Do you have custom content in your Library, which would be displayed in the Node menu when searching for a node while in a graph?
  • When reproducing the issue, place the cursor on the Memory field in the status bar at the bottom of the main window. Wait a short time for a tooltip to appear. What are the values displayed?
Thank you for your patience and help!

Best regards,
QA Analyst
Substance Designer Team

    Hello, Luca,

    Thank you very much for your reply, here are some more information.

  • This is a screenshot of the General section in my Preferences window, I have never previously changed any setting in the Preferences, I also did a clean reinstall by going into Regedit and APPDATA folder.
  • I tried to set these values to Custom and put higher values, but the problem still occurs.

  • I notice in SD 2021.1.1, every time I change any node value in the parameter, this loading bar appears, I have never seen this loading bar appear in SD 10.1, I'm not sure if it's the new feature, or it may relate to the problem.

  • Here is the screenshot of the Job Scheduler in SD 2021.1.1, I compared SD 2021.1.1 and SD 10.1, I don't notice any difference. I only had a shape node and a transform node in the graph.

  • I'm not sure if this related to the problem, but some of the node thumbnails are missing in my SD 2021.1.1, no matter how long I wait or restart SD, they will not show up.

Here are some more things I notice that might help you investigate.
  • I tried to open an SBS I download from a substance source, my SD 2021.1.1 actually open, load the graph, load the thumbnails pretty fast, it's only when I start to change the value of a node, SD became slow and laggy
  • the gif scenario I initially post, the same "a shape node and a transform node" setup, even I set project resolution to 16x16, it still as slow and laggy as 4096x4096
  • when I was using SD 10.1, the CPU usage is always stay over 15%, even if I don't do anything. However, SD 2021.1.1, the CPU usage only spike to 15%-20% when I open projects, changing values in prerameters. so I don't do anything, the CPU usage will drop to 0%

I speculate that it's because I'm running SD on a Laptop, that makes the new version of SD running on battery saving mode or switches to Intel UHD Graphics automatically. I tried looking into Intel(R) Graphic Control Panel and NVIDIA Graphic Control Panel, and Battery setting. but I don't found any possible solution.

It seems to be a very rare problem, I asked a few friends and searched the forum, no one seems to have this problem. I'm sorry for the trouble that brings you, thank you for willing to help me with this problem.

Best Regards
Last Edit: February 24, 2021, 04:38:45 pm

Hi Yi,

I have the same issue and this appeared after downloading extra grunge maps in separate folder with same name as the default grunge maps.  I thought about reinstalling the software and not using the extra grunge maps, since I am not sure what would happen to the dependencies if I rename them?  I have been off an on with SD for some time now and mostly used bitmaps to get materials.  Plans are to finally spend some time to learn the program for real, and I cannot say for sure if the above is what caused it?  The rebuild of images seems to work here and there, then I reopen and find many missing.
I also tried reducing dpi and all of the suggestions here.  Nothing really works when I come back they are still missing.
Computer I am using is:
windows 10
quadro rtx max q 5000
Intel(R) Xeon(R) E-2276M  CPU @ 2.80GHz   2.81 GHz
Latest drivers nvidia

Last Edit: February 24, 2021, 04:28:54 pm