Author Topic: Materials will not apply to any Mesh  (Read 179 times)

Hello,
I tried a Substance 30 day trial in April of 2020. Everything worked great with every tutorial I did.

Decided to purchase a subscription today to finally start using this in my job work flow as I move from rigging to texturing more mesh.

When I use any mesh - Mesh i make - Simple primitives out of Maya - and even the default sample objects from Substance Painter I get this - the base default material like 'pbr-metal-rough' is all that is applied and all i can really see is an environment reflection in it. If I try to apply the most basic material like copper or iron it doesn't change and sometimes will crash the program.

Some materials like Denim will apply what looks like a height or normal map so you see the grain/texture of them but the color never shows up.

Trying to figure out if anyone has seen any of these issues before or if I am just not doing something basic to get this stuff to work right.

I have tried the most recent version of substance - I have uninstalled and reinstalled older versions. Doesn't matter what I do it is the same every time.

There is also some weird reaction with the environment on the material I have never seen before:
https://gyazo.com/247a8457304efde6eb7f215edf7fab12

It is all on all versions of the program.



Not sure why materials no longer just apply like they always did before. Or why it will just crash now. Or have strange environment reactions.

Before when I dropped a gold material on the layers panel the mesh just turned gold. Now it stays the same or crashes. It seems like the only material that will change is the one in the default base materials display window like in the Gyazo video I linked.

Thanks for any info or suggestions.


Computer INFO:

Intel(R) HD Graphics 4600 Graphics

Can you attach a log file as per: https://forum.substance3d.com/index.php/topic,22451.0.html

Are you sure you don't have an AMD GPU? I see you're listing Intel(R) HD Graphics 4600 Graphics, but integrated GPUs are not supported.

https://docs.substance3d.com/spdoc/technical-requirements-172824034.html

Hey,
Thx for the reply.

I attached the log file. My laptop is the same one I used to do 30 days worth of tutorials in 2020. They all seemed to work great so I am not sure what changed between now and then.

This is the exact laptop I have from MSI:


Sorry it looks like it is GeForce Graphics - that wasn't listed on the system settings.
I am checking now to see if this got disabled or isn't running for some reason.

Edit: This is 100% working now.

Thanks again for looking at this. You were correct about checking on the graphics card - It was only using the integrated graphics. I didn't realize the card was actually a GeForce and was not showing up anywhere in the device manager or system information ect. This laptop is around 6 years old now and I had to research why the card was no longer showing up. There is an actual physical button on the laptop you have to press. It has always just been on, one of the kids was probably messing with it. No idea... now that I have restarted and and am re-updating the drivers I think it will probably work fine.

Thanks again and sorry to bother.
Last Edit: February 11, 2021, 09:52:14 am