Author Topic: White screen/crash despite Troubleshooting  (Read 883 times)

I'm a hobbyist and infrequent user. I decided to revisit the 2018 Lantern tutorials by Wes on YouTube to brush up. 

After the first couple crashes, I loaded the mesh in Maya LT 2020 to check if it was a system problem. That took a couple of seconds to load so I knew it wasn't my computer.

I attempted the following fixes, all to no avail:

- fixed registry editor to include both Tdr keys (set to 120 sec to be sure) -- the log mentions TdrLevel: None, but I can't find this in the documentation; if there's a correct value to add, please tell me.
- changed the Virtual Memory paging file size to 24GB
- Turned off Norton 360

After each change I checked the Log file to see if I could find anything. The common Warnings in all of them related to Iray, starting with "MDL search dir path not found" in multiple directories then more Warnings about "Alg::connectSlotsByName: No matching signal for applicationStarted()" and more of the same.

The mesh did load a couple of times but then Painter spontaneously shut down before I could do anything.

I'm willing to delete the 7.1.0 and download the 2018.1.0 in the tutorials if that's the easiest fix, but it would be nice to be able to use the current version. Please let me know how to proceed, thanks.

Update:

I used Revo Uninstaller Pro in Advanced Mode to remove the 7.1.0 in case there were any stray files or registry fragments causing the problem. I then reinstalled the 7.1.0 with the same result and the same log file.

After removing it, I then installed the 2018.1.0 from a previously purchased license key.

The project loads fine and Painter is stable with no issues so far.

Oddly enough, the current log file shows similar Warnings as the one from 7.1.0
I'm including it should you wish to compare and isolate the source of the problem.

The white screen freeze at startup is an issue we haven't been able to reproduce so far on our side.
The only trick that seems to help in some cases is to manually remove the registry settings of the application: https://docs.substance3d.com/spdoc/crash-or-freeze-during-startup-182266673.html

You can also check out our other support page to see if something else can help as well ?
I suppose your system is up to date ?

- fixed registry editor to include both Tdr keys (set to 120 sec to be sure) -- the log mentions TdrLevel: None, but I can't find this in the documentation; if there's a correct value to add, please tell me.
You probably have a typo, check again our step by step guide just to be sure: https://docs.substance3d.com/spdoc/gpu-drivers-crash-with-long-computations-tdr-crash-128745489.html
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

It wasn't a typo. The reason I mentioned TdrLevel was because it's in the Log file, see below.

[INFO] <Qt> "[DBG INFO][GPUIssuesCheck]" TDR information:
[INFO] <Qt> "[DBG INFO][GPUIssuesCheck]" "-Registry TdrDelay key: '120' (int type)"
[INFO] <Qt> "[DBG INFO][GPUIssuesCheck]" "-Registry TdrDdiDelay key: '120' (int type)"
[INFO] <Qt> "[DBG INFO][GPUIssuesCheck]" "-Registry TdrLevel key: None"
[INFO] <Qt> "[DBG INFO][GPUIssuesCheck]" Current TDR delay set to  120 s


I checked for any Windows Updates; there was one minor Stablility update so I installed that then uninstalled and reinstalled Painter and did check RegEdit for Painter duplicates as you suggested.

When I started the program, I inadvertently used a Trial key for 5 days that was available (none showing on my account) and it seemed to work. I changed it back to my license and it crashed again. I only noticed because there was a different Warning at bottom of the screen.

Perhaps this was from your end since when I attempted to duplicate, it now said 'Maxwell' at the top.

I will keep trying, but while I have you here, since I have a GTX 1070 (with current SD driver), will changing any settings for Iray or Sparse in the Settings panel help to resolve this?

I haven't found the source of the problem, but I have fixed it.

It did improve slightly after I fixed the 3D NVidia settings but it still crashed.
I kept researching and found this on Polycount:

https://polycount.com/discussion/185748/problems-with-substance-painter-viewport

Luckily I have RevoUninstaller Pro which finds all the files and registry entries left behind. So I ripped out the NVidia driver using that and there were many files left behind found on the Advanced Scan that were deleted before I did a clean install of the newest SD driver.

It would then load the samples in 7.1.0 but still crashed.  As everyone knows, it's impossible to get an RTX card or system even if you want to pay but there was a sale on RAM, so my system now has 64GB of RAM. Perhaps the typo is in the Technical Requirements and 16GB of RAM is no longer accurate.

My original setup was:

Asus Prime H270M-Plus motherboard
Intel i7-7700 3.60 GHz with 16GB RAM
EVGA GeForce GTX 1070 with 8GB VRAM
Samsung EVO 850 SSD 250GB HD for C:

The C: drive is too small but the D: drive is Seagate 6 TB SATA III, so I changed the Local Cache and Temp Cache to D: and that's working.

There was also a sale on SSD so once the new C: drive is in (Samsung 860 EVO 1 TB SSD) there should be no problems from my end, at least until the next release.

As an amusing side note, I showed the log file to a friend who knows much more about these things. I asked about the warnings in the log about the Iray dso path. He replied, "The software is supposed to set the path, but you're dealing with Adobe which means you're paying to be their beta tester. They've been proudly blaming the customer since the first buggy release of Photoshop. Get over it and do it yourself". 

I created the directory paths and the error messages went away. Painter still didn't work, but I felt better. I even got rid of the annoying Substance Source Plug-in log message by manually deleting the registry key.