Author Topic: Substance Painter wont launch, at all.  (Read 391 times)

Hi,

I'm new to Substance Painter and have been trying to resolve this issue all day. The software won't start at all. The most I'll get is a loading icon by my mouse and then nothing, not even the splash screen. I can't find any logs in the AppData and have tried everything the crash section said.

I've also updated my drivers, checked the firewall, uninstalled and reinstalled the software on both my hard drives, tried installing the previous two versions, restarted my pc and so on. I'm just at a complete loss.

Same thing happens with Substance Designer and Substance Alchemist.

Anyone know why this would be happening?

PC Specs:
Windows 10 64bit
Nvidia GeForce 1080
Intel i7-7700K 4.20GHz
32GB Ram

Make sure you go through these links first:

https://docs.substance3d.com/spdoc/startup-issues-182266556.html
https://docs.substance3d.com/spdoc/crash-or-freeze-during-startup-182266673.html
https://docs.substance3d.com/spdoc/software-conflicts-147095610.html

Majority of the start up issues I see are caused from the wrong GPU being used on start up. You can check if this is the case by a number of ways.

1. Make sure your display cable for your PIMRARY monitor loading Painter is connected to your GPU directly, and not motherboard.

2. You can try disabling the onboard in Device Manager to check, and usually once Painter loads fine you can go back and re-enable the onboard.

3. (Recommended) Force your GPU to run by setting it in your NVIDIA control panel under applications.

If the above doesn't work then check the links I posted and see if there is a software conflict.
I teach people how to use Substance Painter. :)


1. Make sure your display cable for your PIMRARY monitor loading Painter is connected to your GPU directly, and not motherboard.



This worked! Can't believe I didn't think about that, cheers!