Author Topic: Urgent: histogram modifications through SAT present severe look diffs  (Read 843 times)

Substance Automation Toolkit: 2020.1.3

Substance Designer
Editor Version: 2020.1.3 (10.1.3) build 3687 commit 0f34f9e9 Release (2020-06-11)
Cooker Format Version: 3.0.0 commit 0x00000000
Engine Version [OpenGL 3.x]: 7.2.9 commit 0x51db286b (2020-06-11)
Bakers Version: 2.4.0 commit 0xb61270a1

Substance Cooker 10.1.0 commit 0xd6d2c783

Given an input bitmap and an output, when an sbs is run through the SAT, any levels or histogram scan adjustments behave violently different than what is observed in the 3d/2d view, and local exports. Diffs only occur through SAT. A finely tuned mask will most usually get blown out to pure white.

I have checked with pipeline that enough memory is allowed, that position maps are baked correctly. The project will not have enough dedicated access to farm GPU machines so a fix for a potentially major CPU diff is in order. Must also note that this occurs when I run SAT on my local machine through automator not just on farm. Some help debugging would be appreciated.

I am unable to provide any files.

Thanks
Last Edit: January 06, 2021, 05:27:23 am

Hello,
This is a possible difference between CPU and GPU engines.  To confirm this option can you change SD with SSE engine (cpu) and see if you have the same result as SAT? 
If this is the case I will discuss that with the engine team.
Thanks.

Previewing with 2d/3d view and exporting outputs locally with OpenGL 3.x (7.2.9) and SSE2 (7.2.9) return the same expected results - they're close enough that I haven't bothered to closely compare the outputs. It's only when going through automator that any histogram modification becomes a severe problem.
Last Edit: December 23, 2020, 01:35:13 pm