Author Topic: Texture Glitch  (Read 650 times)

Hey guys,

i just started using the Substance Plugin for Unreal and came across 2 problems i could not solve.

1. When i try to download Substance Materials inside Unreal Engine via the Substance Source Tab i get the Error that Materials cannot be downloaded or UE Editor crashes when i just try to login into Substance Source in the Engine. So either way Substance Source is absolutely unusable for me in the Engine.

2. Now as i cannot download inside UE i just get materials from Substance Source externally and download them to a folder in windows and import them into Unreal. As far as i understand, the Substance Plugin recalculates the Texture inputs when i adjust the parameters of my material inside the engine. When i import a Substance Material inside UE and try to use it i get some weird "stepping effect" kind of glitch in the textures. On some of the wood planks there is some pixel offset going on completely destroying the correct look of the wood. It happens with other materials too. You can see the glitch in the screenshot. I tried to find online what's wrong but i can't find a thread describing that problem.

Is there anything i'm doing wrong or is it a bug/problem occurring only on my system?

Thanks for your help!

Hey guys,

i just started using the Substance Plugin for Unreal and came across 2 problems i could not solve.

1. When i try to download Substance Materials inside Unreal Engine via the Substance Source Tab i get the Error that Materials cannot be downloaded or UE Editor crashes when i just try to login into Substance Source in the Engine. So either way Substance Source is absolutely unusable for me in the Engine.

2. Now as i cannot download inside UE i just get materials from Substance Source externally and download them to a folder in windows and import them into Unreal. As far as i understand, the Substance Plugin recalculates the Texture inputs when i adjust the parameters of my material inside the engine. When i import a Substance Material inside UE and try to use it i get some weird "stepping effect" kind of glitch in the textures. On some of the wood planks there is some pixel offset going on completely destroying the correct look of the wood. It happens with other materials too. You can see the glitch in the screenshot. I tried to find online what's wrong but i can't find a thread describing that problem.

Is there anything i'm doing wrong or is it a bug/problem occurring only on my system?

Thanks for your help!

@Niandra1357 ,

Yes the Substance Source section of the UE4 plugin is currently not working as intended as you mentioned. What Substance sbsar are you using from Substance Source so I can take a look?