Author Topic: Substance Launcher refuses to install  (Read 2050 times)

I go to install it and it goes right to this.

Same here! Dont know why, i just wanted to reinstall it on a new hard drive...
2 Days ago it was working fine...

Wow still no reply from staff.... Awesome support guys  ;)

Hi Harpyen,

Sorry for the late answer

Not being able to install Substance Launcher can be due to several issues.
The main one is when you "re"install it : if not uninstalled properly there can still be a substance launcher still hidden somewhere in the Registry.
I invite you to access your Windows Registry and try to find if anywhere there still is a Launcher hidden ...

Most of users complaints about not being able to reinstall was due to this. Windows can sadly be a pain to use sometimes and this default Windows wizard/installer just freezing is not very helpful -_-' !

Hi thx for you answer.

Yes i made a reinstall. Using uninstall.
I cleaned all left overs in AppData and where i could find something.
I also did this:

Still not working....

Any more tips?

Sadly not
So far most of the time the issue was due to those launcher leftover's in the Registry.
You could also try using some specific registry cleaner such as CCleaner. Still be careful with the use of this kind of tool when you clean the registry since it can break a few things on the way. Nevertheless most of the time everything just goes fine.
It may be able to clean those leftovers from uninstalled app

Windows can behave in an erratic way from time to time and those Window's default installer/uninstaller we use can't allow us to debug those kind of very specific issues ... (no logs you can export or share with us, no error code, ...)

Using CCleaner worked!

Best Regards