Author Topic: Substance Source Link in Painter does not work correctly  (Read 1130 times)

I upgraded my Painter the other day and now my substance source link does not function properly. I have to go to the web page and download manually.  Here is what it looks like when I open substance source from my Substance Painter.



Same here, nothing displays.

Hi Thomas,

We don’t provide the Substance Source integration anymore in Substance Painter.
We encourage you to use Source in Substance Launcher, which has a better experience with the "Send To" Painter and which has more functionalities.
PO @ Allegorithmic

Could you guys, at the very least, remove the icon from there?   :-\  I'm paying, you know?  I do expect better than this behaviour of just making decisions without considering the impact that it might have in the artists current workflows at all? You are not 'encouraging to' - You are effectively 'forcing to' : that's totally different, since otherwise one has to manually incorporate the owned + the acquired materials.  This is a huge time loss / impact.   

At the very least, if you are to decide to leave an icon in a tool bar that doesn't work anymore, can you set a tool-tip that offers the information offered above, or something, so we don't need to search on the net for the answer to what just happened?  I'm sorry but I must be honest about this, I totally found this to be quite annoying and irresponsible design stuff for such a huge company. 

Then, why are you forcing me to use an important feature, from within a helper piece of software that doesn't install by default neither!?   :o  Wow...  Such a bad way of imposing over user experience, via software design choices that are not apparent at all.  Guys, you're a huge and experienced company!  This is very disappointing stuff.  I just hope you guys don't start taking such an irresponsible approach as the 'standard operating procedure' for future updates. 

I wasn't going to post this thinking that it be removed in actual versions since I haven't had the time to update but, I did updated -> 2020.2.2 (6.2.2) and it's still there! Wow...  unbelievable...  ???


- Luis