Author Topic: sbsrender doesn't understand Raw output colorspace  (Read 1985 times)

please help! I render my sbsar outputs (for mask usage) with sbsrender and specify Raw color space. Result file is the same as with sRGB. When I specify Linear I get totally black texture.
However when I render it in designer with Raw color space it produces excellent result that I need. I need exactly Raw, because my texture holds channels of object normal texture plus masks.

I've just have bought substance designer thus I have the latest version on SD and toolkit.

Outputs usage tags don't help. There are no log messages, everything looks working ok, but doesn't give me a valid result.

I tried these options, but nothing helped:

--set-output-colorspace output_2@Linear
--output-colorspace Linear
--set-output-colorspace output_2@Raw
--output-colorspace Raw
 --output-format tiff
 --output-format tga
 --output-format bmp
 --output-format png
--output-bit-depth 16
--output-bit-depth 32f
--engine "c:\Program Files\Allegorithmic\Substance Automation Toolkit\plugins\engines\substance_d3d11pc_blend.dll"
--engine "c:\Program Files\Allegorithmic\Substance Automation Toolkit\plugins\engines\substance_sse2_blend.dll"

Also I tried to export each channel separately but sbsrender broke each channel by "pre-sRGB".
Please advise, maybe there is some workaround to get raw textures from sbsrender?
I tried to convert back to linear by applying 0.45 gamma in photoshop but result is totally different and unusable.

Just in case here is my command line
Code: [Select]
render "%MyVarSubstance%" --set-value '$outputsize@%MyVarRenderRes%,%MyVarRenderRes%' ^
 --set-entry input_ao@%MyVarTgt%\%mesh_name%_ambient-occlusion-from-mesh.tga ^
 --set-entry input_curvature@%MyVarTgt%\%mesh_name%_curvature.tga ^
 --set-entry input_ID@%MyVarTgt%\%mesh_name%_color-from-mesh.tga ^
 --set-entry input_obj_normal@%MyVarTgt%\%mesh_name%_normal-world-space.tga ^
 --set-entry input_position@%MyVarTgt%\%mesh_name%_position-from-mesh.tga ^
 --set-entry input_normal@%MyVarTgt%\%mesh_name%_normal-from-mesh.tga ^
 --input-graph-output output_2 --output-format tiff --set-output-colorspace output_2@Linear --output-path %mesh_path% --output-name %mesh_name%_dce

I was wrong, even with sRGB substance designer and sbsrender results are totally different! Why is that? I made sbs/sbsar in  designer and expect the same output by sbsrender! Please help!

Guys, what are you made toolset for? I had to code this render task as designer python plugin, your sbsrender is just a trash!

Hello, thanks for the feedback  ;)
I did some tests and everything looks fine here. Here the commandlines:

Code: [Select]
sbsrender render 'brick.sbsar' --set-value '$outputsize@10,10' --input-graph-output 'output' --output-name color_from_sbsrender_sRGB -vvv

sbsrender render 'brick.sbsar' --set-value '$outputsize@10,10' --input-graph-output 'output' --output-name color_from_sbsrender_Linear --set-output-colorspace 'output@Linear' -vvv

FYI, in Designer terminology, "Raw" is sRGB for a color output (at least for legacy color management), so it's better to use Linear.

What is your sbsrender / SAT version?
Did you use specific colorspace configuration inside Designer (ocio / ace)? if so did you cook it correctly ?