Author Topic: Nag Screen in Vray5/3ds 2021...  (Read 2431 times)

I've been experiencing crashes and massive slow downs in my files, under two circumstances.  Not sure if the title of thread is part of the issue, but every time I either start the IPR in VR5, or close it,  I get a pop up nag screen indicating an incompatibility issue between Substance, and Vray, and that the pop-up offers to run a script to make thing right. Of course I push yes, because Sub is supposed to be comparable, right?

So I push "fix", or whatever the message wants, I also check "do not show again"...but then when I close the IPR, in the very same session, the nag screen pops up again.  By now, in a month of daily use of Vray5/3ds 2021, I've pushed that button hundreds of times.  So I wonder, because of what I'm about to write, if the Substance pluggin is running a script every time I get this message, and interfering with the IPR, and 3ds/vr5, because, in a fresh, virgin scene, with no materials assigned, the moment I apply any substance designer material, whether I make it myself, or download it from Source, the IPR hangs and will not render, and/or, it hangs in a terminal loop, AND crashes the program (and if I let it loop, I have a feeling it would cook my hardware... 

I have done my homework, done tests with new files, for the past two weeks, and I have narrowed this behavior down to the application of Designer materials, (no matter if the mat is one d/l'd, or made).   

For instance, last run through, just this evening, with a completely virgin file (a dwg arch viz model imported from Revit with no mats I have been using as a test bed, and I am making copies of it so every time I do this, the file is untouched to begin), So using this file, I can run the iPR without issue for as long as I want, applying roof textures, exterior colors, etc... Next, I reload the next cloned copy (again, virgin), apply a single stucco from Source, nothing else, and immediately, and on the first push of "start IPR", the IPR now hangs, and renders no further than a fuzzy blob...  Ironically, upon closing the IPR ( slow, near crashing) I can no longer use IPR, but I can use production render without issue.

Next, as a related aside;  I want to get on the record, right now, as well. The first time this happened to me, as I inferred above, (cook hardware) after applying a Designer stucco material, the machine hanged, and I waited for the issue to "resolve itself", because I thought it was just working things out, for itself, rendering or processing through, as things typically do, with rendering mats and renders.  After a number of minutes, I soon realized that something inside the box was seriously overheating, as there was a smell of "hot ozone".  It was not the CPU, because I have a digital readout in the cup block, and that was in range.   (I know what toasting components smell like, btw), and so I force quit, opened my glass front case, and put my hand over my GPU, and it was so hot, it would have literally burnt my hand if I kept it on the GPU.  I literally could not touch the gpu for perhaps 4 or 5 minutes, and even then, it was "cooking".  This was a serious, serious issue, and from that point on, anytime the machine showed any inclination of hanging, I'd go straight to CTRL/Alt/Del, force the quit.

So this is a deadly serious flaw, and I am beyond nervous because my computer was only a couple weeks old at the time, and that GPU cost me $800.   

Next, back to the material issue,  if I try and change a parameter in the Source mat, when I attempt to change the color of the mat with the stock vray color selector (a simple 2 node stucco color) then the prog slows to a crawl, then crashes, every time.  To date, if I try to change any color/saturation/hue sliders, or simply the color, it crashed the entire rig.

I promise, this only happens when I apply a substance mat, but the nag screen is so persistent, and this condition is so distressing, I am considering not only abandoning a program I bought only a month ago, but the whole enterprise.   It's been hell, to be honest, and I'm completely disillusioned at this juncture.  And I worked hard, hours,  to isolate the problem, to the Substance material crashing. 

I am a full time professional residential architect, self employed, and I have wasted probably 60 hours on this issue, floundering on a home I wanted to have rendered three weeks.  Of course, one may argue it was foolish for me to waist that much time on it, I could have done a beautiful digital watercolor in PS in a day.  But I just built my HEDT specifically so i could put new era CGI into my viz workflow, utilizing 3ds, vray, and substance, as the core trio in my workflow.  I thought your program, in particular, would set me completely free, to be as artistic as I technically could be.  And here I am, a month later, feeling like I just wasted 5 or 6  grand on hardware, steered into a ditch by what feels like buggy toys that are NOT ready to play nice between each other... 

But who knows, maybe I just flipped a switch, while scrolling a roll-out (or not).

So hopefully, someone (from Substance), will come along, read this essay, and prove to me what a fool I really am.
I honestly hope so, because my brand new rig has been seriously stressed and cooked, on my first application of my first substance mat., and I knew it was trouble the moment it happened. 

My machine specs are; Ryzen 3960 on a water loop, Radeon Pro W5700, 64g ram,  all sitting on top of a ROG Zenith II Extreme Alpha. 

By the way, I had such a high expectations for the whole Substance Suite, as I have been using Adobe products for well over 20 years, and I've been subscribed to the creative cloud since day one.

As a professional, I need to either get this resolved, abandon my ambition, or just get back to digital watercolor, especially if there are true compatibility issues that are months from being resolved. 

Most, I need some serious attention to fix what has been laid low.

Last, yes, my GPU, etc., have all the latest drivers, so please, do not insult my time further by playing that game, I would prefer to cut straight to the chase.

Thank you for your prompt attention, and I honestly hope we can come to a reasonable solution.

My very Best,

M. Cooper
Last Edit: August 13, 2020, 07:03:16 pm

The script thing should be unnecessary, and shouldn't occur in the newest version of the plugin. We have released many versions since 3ds Max 2021 was originally released.

I have not been able to test with VRay 5 yet, although it worked fine with VRay next. I'll test it and we'll look at making any alterations we need for VRay 5 in a 2.4.1 release. As we're currently working on the next feature release with more direct Arnold support, any changes won't be immediate, but we'll try to address any changes made sooner, before the next large release.
Last Edit: August 13, 2020, 07:33:07 pm
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

Thank you for your forthright information, Galen.  I appreciate honesty.

And so, in the mean time, I just wait?  How long, do you think? 

I have to progress my workflow along, with or without Substance, and in it's current iteration, I think you need to understand the software that I purchased the program for is completely unusable in it's current format.

So is there anyone I may speak to about my subscription? Because I have purchased a thing, and that thing is broken.  It is not my fault the software is not coordinated with a program it is inferred to be compatible with, so at a minimum, I hope you can understand my position.  At the least, I would be happy to give it another shot, and I will even be happy to test, in the wild, for you all, once it's fixed, but I have to say that I should at least be credited for the time I cannot use it, until you all resolve your issues.  Or I feel like a refund is in order if that is untenable.  However, as I mentioned, I am an Adobe customer, for many, many years, so I hope you all can appreciate that I am willing to bend, and deal with issues, but this would have to be mutual.  Feel free to contact me off forum, or reply here, whichever is appropriate, but please, don't just leave me "hanging", and clueless.
Last Edit: August 13, 2020, 09:57:44 pm

As we have to make alterations to resolve your issues, yes, you will have to wait. Hopefully not that long, but it will take some time.

It will take more than a day to test it, reproduce the issue, make alterations, test those and then release it, on top of changing what we are already working on. It will take some time, and it is near the weekend.

There is a lot to unpack in the original post and not all of it is related. Some of the issues, such as the annoying dialog, were fixed in previous versions. Others we will have to investigate, such as the crash with VRay 5.
Last Edit: August 14, 2020, 03:26:55 pm
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

Thank you, and if there is anything I can do, I will.  I do have more info on exactly what happens during the freeze/crash, I just didn't want to make my first post so cumbersome as to be unintelligible.

To wit, when this is happening, (with a Sub mat applied to a model, then starting IPR in VR5) max produces an error code indicating IPR cannot be used with distributed rendering on.  The irony here is that the only to switches I am aware of that trigger DR, are both set to off (unchecked). 

Also, in one of the small windows visible in the stalling IPR, a message is looping "starting Embry cache" + plus something unintelligible, (perhaps to do with DR?), and this little message just loops infinitely .

Again, using my test model, none of this happens, and only after I apply a Sub mat, then start IPR.

In the event you cannot reproduce the error, perhaps we could arrange a remote session, because I can reproduce it every time...  Just a suggestion.

Are you using VRay 5 or VRay 5 GPU? I did manage to run into problems as well when using VRay GPU and using an 8K Substance Texture, but I'll have to keep trying with normal VRay. I'll also go back and try with the 2.3.1 plugin that came with 3ds Max 2021.

Embrie I think is an intel library for ray tracing, so it sounds like VRay is using that for rendering.

For VRay GPU, we will probably need to do more bespoke work to get a more direct compatibility, I would definitely recommend sticking to normal VRay 5.

With the newest plugin, version 2.4.0, the renderer compatibility window that was annoying does not show up anymore, so that at least has already been fixed.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

I never use GPU rendering (yet, anyway, until I can better comport myself with the softwares).  So it sounds like you are inferring I should use lower res mats.  However, I don't recall see that as an option in my d/l's.  I'll revisit the Source, and I will reload, and revisit this thread.  I also wonder if it has to do with my hardware combo? And one other nuance; I understand 3ds 2021 is written in the most recent version of Python, and that may be the culprit in other plugins woes?

Thank you for your timely response and attention.

Materials have a dynamic resolution, ranging from ~32 pixels to 8192 pixels. Running at 8k with VRay 5 GPU caused issues, but I'll need to do further tests with just VRay 5 then. I'll also need to test with different versions of the plugin.

Python probably has nothing to do with it.

It could be odd combination of hardware doing it, I'm not quite certain. As of now, the only machine I've been able to get the VRay license server to run on has an Nvidia Quadro card, so that is all I can test with at the moment.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries