Author Topic: 3dsMax 2021, Vray 5.0 render error  (Read 3563 times)

Hello,

I've recently updated my workstation and rendernodes to Max2021 and Vray 5.0.

Now I ran into an error for which I haven't found a solution yet.

Everything is rendering fine when I use Distributed Rendering, but at the point when I want to submit a job to the backburner app it won't start.

I get following error shown in the backburner server:

Adapter returned unexpected code -2 for "C:\Program Files\Autodesk\3dsMax2021\maxadapater.adp.exe" "-o" "NewTask" "-1" "Info" "-j" "C:\Users\xxx\AppData\Local\backburner\ServerJob\filename.xml.details" "-s" "192" "-n" "l" "-u" ...
Task error: 3dsmax adapter error: Autodesk 23.1 reported error: Error executing script
Application is down

I checked whether I can see which script is causing this error while connecting via RemoteDesktop.
It turned out that 3dsmax was launching but kept quitting when following scripts were opened or trying to be opened (popup window):

SubstancePreRenderCompat.ms and SubstancePostRenderCompat.ms


I uninstalled my older 3dsmax version and vray version cleaned the folders and reinstalled 3dsmax2021 and vray 5.0.
I then tried to use a blank scene to make sure it wasn' something hiding in the current scene.
But the error came back.
Tried to render via backburner on my workstation but the same error again.

So, does anyone here have a similar problem or does maybe someone know what's causing this error?
Any help will be much appreciated.

Best regards, Niklas

I'm not certain what causes the error. I'll put a ticket in for it so that we can address it in one of the 2.4 patch releases.

The 2.4.0 plugin is soon to be released and is finalized, so any changes will have to be after that.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

me neither  ;D
alright, hope it will be fixed in the new version (if it's related to Substance). Thank you for the fast reply.

It has been figured out,
the guys from Autodesk gave me the hint to remove all scripts in Render Setup - Common - Scripts

So everything's fine now. Feeling bad that I haven't thought of it myself.
Case closed I'd say.
 :)

Ah yes, I have seen it, a few years ago now that I think about it. I think there might also be a checkbox somewhere to tell 3ds Max to send the pre/post render scripts with a backburner job, but just removing them should be fine.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries