Author Topic: Substance in UE 4.25.0.1  (Read 153 times)

Hello, i am having some troubles with the material generated when i import a sbar.
It seems that if the material doesn't have an ambiant occlusion it apperas black in the viewport in lit mode.
If i use the textures generated in a new material it shows in viewport perfectly.
Anybody having the same trouble?
Thanks for your time

Hello, i am having some troubles with the material generated when i import a sbar.
It seems that if the material doesn't have an ambiant occlusion it apperas black in the viewport in lit mode.
If i use the textures generated in a new material it shows in viewport perfectly.
Anybody having the same trouble?
Thanks for your time

@tomgauthier ,

What version of UE4 and Substance plugin?

Are you importing the sbsar directly from the Substance Source in UE4 window or importing it manually?


Hi, thanks for the reply.
The unreal version is Version: 4.25.3-13942748+++UE4+Release-4.25
And the substance  version is the 4.25.0.1

I import the sbar through the import menu in unreal and it generates the textures and a material automatically.
As it always did.
The material instanced of the material created is the "Substance_Baisc_Template".

And the only "problem" i have is that if there is no ambiant occlusion assigned... it appears black.
If i put a white texture it appears correctly.

If think in the previous version of the engine i had no instance material for the sbar generated.
 It was a material with the textures generated assigned.
And this is why if there were no ambiant occlusion texture generated it didn't appears in the material graph.
I don't know if i am clear but it sound like an self-answer for now.

Maybe there should be a default white texture for ambiant occlusion instead of a the "default_color" black assigned.
If i am not mystaken.