Author Topic: Substance to UE4 Livelink Not Working 4.25  (Read 6556 times)

Hey guys,

We have a fix in for this and are in the process of testing it. We should have a release within the next week or so. Thanks for your patience, and sorry for the inconveniences to your projects/workflows. :(

In the meantime, there is a workaround (I posted this above):

The latest versions of Substance Painter (6.2.0, 6.2.1) seem to be having problems with the dcc-plugin side of it and UE4. I looked a bit into it, it seems to work as expected if you use Substance Painter 6.1.3 and below.

Hello there,

Just wanted to ask if there is any progress on solving this issue? :)

Dino

Hello there,

Just wanted to ask if there is any progress on solving this issue? :)

Dino

Hey @rook_ofc ,

We have a fix for this issue in the build on our side, but there have been some issues that have cropped up that we are trying to solve before we release. Hoping to get that resolved soon, sorry for the delay. :(

Thank you for your answer @-kg- :)

I know you guys will fix it when it is ready and I'm glad it will be soon.

I was just worried that it might be abandoned.

Thank you.

Thank you for your answer @-kg- :)

I know you guys will fix it when it is ready and I'm glad it will be soon.

I was just worried that it might be abandoned.

Thank you.

Hey guys,

The UE4 Substance plugin was released today that fixes the livelink issue in 4.25 and the latest versions of Substance Painter. Try it out and let me know if you have any other problems. Thanks! :)
Last Edit: November 10, 2020, 07:53:13 pm

Same issues. I have a video as well: https://streamable.com/lsbs8i

Cheers!

Having this exact problem as we speak. Using the updated version of Substance as well. Not understanding what to do. It's unfortunate because I'm working with large pieces of modular architecture and it's becoming quite the pain

I managed to solve the type error problem.
[Plugin - dcc-live-link] No defined association with the exported (. $ Udim) 'map
The problem was in the default texture export preset for ue4.
You need to remove the key (. $ Udim) at the end.
SP wouldn't let me change the default preset.
I duplicated the default preset and changed it, then I found it on my computer in the docs and then renamed it "Unreal Engine 4 (Packed)". Then I copied the changed preset to the main SP folder along the path "Substance Painter \ resources \ shelf \ allegorithmic \ export-presets" with replacement.
After that, textures are now created in ue4.

In short, you must change the default preset by removing the (. $ Udim) key at the end.

Developers. Please add the ability to select a preset for use with a live link in ue4 .... Or allow the ability to change the default preset ...


Hello,
I was working yesterday with UE 4.26.2 and current Substance Painter.
The exchange worked, but it is not supporting UDIM.
I have exported an FBX with the plugin, that had 3 UDIM tiles, they were visible in Substance, but the project was not set on "UDIM" workflow and this can't be changed.
(and yes, "Virtual texture" is activated in UE)
Please let me know, if there is a fix or if I am overseeing something.
Thanks

Hello,
I was working yesterday with UE 4.26.2 and current Substance Painter.
The exchange worked, but it is not supporting UDIM.
I have exported an FBX with the plugin, that had 3 UDIM tiles, they were visible in Substance, but the project was not set on "UDIM" workflow and this can't be changed.
(and yes, "Virtual texture" is activated in UE)
Please let me know, if there is a fix or if I am overseeing something.
Thanks

Hey @BeneZwo ,

The Substance Livelink in Unreal part of the plugin does not support UDIMs at this time.