Author Topic: Substance > Maya Visual C++ Error  (Read 1808 times)


Substance Versions
Editor: 10.1.1
Engine: 7.2.9

Recently I was having issues with my substance nodes in maya, I would always create a Substance (texture) node, and connect my .sbsar file, Create network.  and it would work perfect

But now, when I do this, my Base Color does not show. And I couldnt figure out why.
So I updated Maya from 2020 to 2020.2

So now I have an even bigger problem..  when I go to create the substance network in maya I get a Microsoft Visual C++ Error (see image)

I re-installed the 2008 Redistribute files and this did not fix this issue
The Sbsar files work perfectly on my other machine. Both identical setups and versions.

Please help with any ideas you may have

For some reason, the Substance Linker is failing to load the Substance file. It has nothing to do with the visual C++ distribution.

If you type 'substanceUtilityGetLinkerVersion' in the script editor, what does it print out?

Perhaps the install got messed up somehow, so maybe try to uninstall the plugin and get the newest installer off the website to reinstall it.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

I get this same exact error. Maya 2019, latest substance plugin version.

When I type that command, I receive this:

// Result: 7.0.0 //

That means there is some sort of old substance linker binary laying around somewhere, the newest one should return 7.2.9. My guess is the old plugin is still installed. What happens is it will load that one first, even if the old plugin is disabled. The linker won't recognize sbsar files from the newer designer version.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

So...okay. How do we go about removing the old substance linker binary that's still on our system?

Could someone write a script to correct this old binary lurking around in our system? I'd love to start my subscription with Substance, but this is a non starter. By the way, I currently have a perpetual license that is up for maintenance soon.

If it's Maya 2019 or earlier, then you can search for 'substance_linker.dll' in the Maya install directory, C:\Program Files\Autodesk\Maya2019 for example, and then delete it.

You will need to ensure that the old 1.0 plugin is completely removed from your system.

The 7.0 version linker is from some odd upgrade path from updating Maya to 2020.1, etc. You can uninstall the plugin, ensure that you delete C:\Program Files\Allegorithmic\Substance in Maya\2020 entirely, then reinstall the newest version.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

Yep. That worked. Thanks!!

Well actually, it looks like SideFX Houdini is running an out dated "substance_linker.dll". Removing it that solved my issue. But Houdini doesn't like it.

Does the Houdini engine plugin distribute with it?

Or do you have your path set to load the files from the Houdini install?
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries