Author Topic: [Solved] Colors not baking in ID map  (Read 4396 times)

Hello everyone:-)

I wanted to bake a ID map inside Substance painter from the material colors of my mesh, so I assigned each polygroup a material with different colors in Maya. But Substance painter doesn’t seems to be recognizing any other colors except green and blue (please see the picture below).

The colors I assigned in Maya.





The baking result in Substance painter. The colors on the window, engine and the top are missing, everything is green (the color I assigned to the body).
Only the spike on the nose was successfully baked (blue).




I unwrapped the UV in UDIM format.
My painter version is 2020.1.3(6.1.3)
My baking configuration.





Thank you very much for your help!
Last Edit: July 20, 2020, 04:12:05 pm

Can you provide the mesh with the color IDs and your low?
I teach people how to use Substance Painter. :)

Test

Edit:
This is very weird, i can't post my reply with my fbx file attached.

Whenever i tried to reply with my file attached I am redirected to a webpage saying "413 Request Entity Too Large openresty/1.15.8.2"
Last Edit: July 20, 2020, 12:47:23 pm

Can you provide the mesh with the color IDs and your low?

I uploaded the mesh to google drive. Please download it via the link below. Sorry i am not sure if this is permitted on the Substance forum. But the reply attachment is not working for me.

Here is the mesh i assigned colors to in Maya, it's also the low poly mesh which i imported to Substance painter.
https://drive.google.com/file/d/18iq8OYnyTFyvUNBR6Y6AaKEwfQR0lKtB/view?usp=sharing

Thank you

Hello,

Looking at you're screenshots, you wil need to add you're highpoly with ID or Lowpoly with ID to you're high defination meshes. Its currently empty.. not loading any mesh. Hope this help you.

Hello,

Looking at you're screenshots, you wil need to add you're highpoly with ID or Lowpoly with ID to you're high defination meshes. Its currently empty.. not loading any mesh. Hope this help you.

Thank you so much Decorix! now my color id baked perfectly.



So you can’t bake the color id map onto itself even if the low poly mesh has the ID color information, you have to load the low poly as high poly mesh in order to bake right?

Thank you and CAGameDEV too for your help, I really appreciate it.


Edit:
By the way how do i mark this topic as solved?
Last Edit: July 20, 2020, 01:37:32 pm

You can just edit the first post and put [Solved] Title.
I teach people how to use Substance Painter. :)