Author Topic: A Problem with Substance Painter Ater Purchase  (Read 672 times)

I just purchased Substance Painter -

I thought I was going to just dive in but I got a message saying "Substance Painter Cannot Open because of a problem".

Check with the developer to make sure Substance Painter Work with this version of OS X 10.10.5.

I am new to this forum and need help.

Thanks,


Darien

Substance Painter is only compatible with OS X 10.13 and above.