Author Topic: Shape splatter behavior  (Read 236 times)

Hello everyone,

I've been searching the forums for this question and I found similar topics but they do not have an answer. As an example:
 - https://forum.substance3d.com/index.php/topic,36367.msg135447/highlight,SHape+Splatter.html#msg135447

An example of the behavior is attached. I was following this tutorial series:
 - https://www.youtube.com/watch?v=5wqRkCxW4ZM&list=PLB0wXHrWAmCwWfVVurGIQO_tMVWCFhnqE&index=11

And in the series it works like a charm out of the box. The rocks have this smooth shape and they fit on the texture quite nicely. However, when I do the same then I always get these binary masked blops, regardless of the input. I've tried tweaking all kinds of options but to no avail and I feel it should've worked out of the box given that it does so in the video.

What am I doing wrong here?

edit1: additional context: this is a default shape splatter node.
edit2: I found a similar question here:
 - https://polycount.com/discussion/203135/shape-splatter-clips-any-value-per-default

But I don't understand the solution. I feel like I've applied that already by lowering the brightness of the shape in question.
Last Edit: April 27, 2021, 11:53:47 am

Try turning up "conform to background" and "smooth conformed background" in the "Height" tab of the shape splatter parameters.

Also I think your background height may have too contrasty small details (small but high spikes and valleys basically) which can cause some shapes to be lifted to to the top of a spike which lifts it higher than you may want. The conform to background should help with this though.

Hi Esger,

Thank you for your response!

The left image is your suggestion: it still doesn't solve the issue. In the right image I started clicking random options until I found something. Apparently turning off the auto scale helps a lot to prevent the issue from happening. Conforming to the background can then remove the last few rough bits.

I still don't entirely understand why the behavior is different from the video, even though we both had the same default node. Maybe it is version related: I use 2021 (steam) and I think he uses 2018.

With default settings, all I have to do is turn "conform to background" up to 1 to get the desired result, as you can see here: https://i.imgur.com/fSTrBrr.mp4

In your screenshot you also have "height offset" turned up. This will lift the shape up above the surface, creating the ugly cutoff. Perhaps this was also previously the problem. Turning it up above 0 is rarely useful honestly.
Turning off the "height scale auto adjust" probably just makes this offset much smaller, making it less noticeable.