Author Topic: Substance Painter not launching  (Read 989 times)

Hi,

A user of Substance Painter, who previously had a working version on the PC, is now unable to launch the software. This is happening on 6.1.2 and 6.1.3.

The splash starts up and disappears but nothing happens after that.

If I launch as an admin Substance does launch but we are unable to load a project or create a project.

I have updated Windows and Nvidia drivers to the latest available. I have also set TDR values as requested by the app.  I have attached error logs and this is the Windows Event error that is given for the program crash:

Faulting module path: C:\WINDOWS\System32\ucrtbase.dll

The launch problem possibly happened around the time we updated our internal tools which run on Python and a few other dependencies.

Thanks for any help,

Adam

Did you try following any of our troubleshooting pages ?
https://docs.substance3d.com/spdoc/technical-issues-162005746.html
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Hi,

Thanks for your reply.

Yes I have tried the suggestions in that help article but still unable to get Substance Painter to launch.

After doing those suggestions and making the user account an admin account I now cannot get Substance to launch at all, even launching as an administrator.

Interestingly the problem started on another computer that has Windows Updates turned off, starting the app as an administrator then updating Painter seems to have fixed it there but not on the original PC.

I've seen from other forum posts of issues after Windows Updates, do you have a timeframe for a version that works with the newest Windows updates?

Adam

I'm experiencing the exact same issue with the same version. I can't pin point exactly what happened But it was working one day, and now it just refuses to launch. I have tried re-installing it and update Nvidia drivers etc.
Any clues?

Hello,

I am still having this issue on a couple of computers.

The latest 2019 version does work but files are incompatible with the ones made in the newer version.

Can we get a fix for this? Or direction to the fix as I have seen a few people have the same issue.

Thanks

Adam

@BlinkInk @magster Please take a look at the troubleshooting page I posted above as a first step and let us know how things go.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Hi,

Thanks for the reply.

As I said on the 3rd of July, I have tried the troubleshooting but nothing works consistently.

The problem has happened on multiple computers now. Sometimes deleting the PYTHONPATH has fixed it, other times the PYTHONPATH doesn't show in Environment Variables and Substance still won't open after the splash.

Other times running the program as Administrator works

The only consistent is that its version 6 doing this.

We do use the PYTHONPATH for our internal studio pipeline tools so removing it is not a solution. Neither is providing the administrator password to users as that violates security laws.

Any help with fixing this, or news on an updated version would be great. I have seen multiple other users with the same issue.

Adam

Hi,

I am still having this issue on multiple PCs. 2019 versions do not have the issue but we have project files started in version 6+ so here I am still trying to get this working.

Any fixes for this issue yet?

I have updated Substance version, checked the PATH and PYTHONPATH, updated drivers (using Geforce Game Ready as Studio drivers are no longer available for the GTX 970), and gone through the recommended advice for instability and startup problems many times.

I have attached another log file.

Thanks

We are also facing this issue. This only happens with Substance Painter and not any other Substance Software. Both Alchemist and Designer are working as expected.

I noticed there is a small popup window that opens with Painter right before it crashes but it happens too quickly to see what it is.

any fix for this? went through all the troubleshooting pages. This is a brand new windows install we are using.

We just paid for a license and can now not use the main software we wanted ..
Last Edit: August 31, 2020, 04:49:37 am

We are currently looking into issues related to the PYTHONPATH that can lead to freezes/crashes. We are trying to fix the problem for our next bugfix version planed in the next few weeks. You can try to run the application without Python meanwhile by using the command line argument "--disable-python".
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Do you run any wacom?   i have a intuos wacom, substance work when i turn it off..  strange..

For those with same problem and are using two monitors, just disable one monitor from windows settings dialog, launch substance, then extend your monitor again. It has been working for me consistently.