Author Topic: "bake mesh maps" feature generates massive triangles amongst other problems  (Read 207 times)

so this could definitely be an error on my part but i cannot find any hints as to what i may be doing wrong if thats the case
basically the "bake mesh maps" feature leaves many of the generated maps full of massive triangles which makes my mesh look something like this

this also seems to break any smart materials that make use of the generated maps
i make my models from scratch in blender as hobby work
i can of course just choose to not use the "bake mesh maps" feature to avoid this error but i feel like im really missing out on some nice texturing features here
any help or even a hint as to what may be going wrong here would be greatly appreciated

Can you upload your high and low mesh? Or DM me a link and I'll look into it for you.

i've DMed you a link to the mesh

So this will be a big post as I have a few things to go over.

When you stack UVs you must offset them to the next UV space prior to baking otherwise you will get artifacts.



These are some of your stacked:



Those triangles are because of your stacked UV shells when baking:



Offsetting means selecting the stack and pressing G + 2 in Blender to move them over.



After baking you can bring them back.

You also need to watch your overlapping. Here are two UV Shells that overlap.





Normally when you get such problems look at your 2D view in Painter and go back into your 3D modeling application and review those troubled spots:



If I select all overlapping UVs I get:



Another issue is you have a lot of separate pieces all combined into one.





So when you bake you'll get these artifacts:



You need to split all your pieces and name them whatever_low, then duplicate that and change low to high for High to Low Poly. As you're doing just a single low you should be able to just do _low and when you bake select Always and it should be fine using the High as Low, but otherwise do the below:





Then when you go to bake load your high fbx file and set these options:



Once you bake you'll notice another issue even though now your current baked version is better than your prior:

BEFORE:



AFTER:



The part which overlaps is causing an issue:





I would just split the object so even though its overlapping they're two pieces and the problem will go away.





You also might notice stuff like this on your normal map:



You'll need to review the geometry to find out why. The best way is to paint a color on the UV where that spot is and look in the 3D view where it matches, or reference your 2D view to your UV veiw.

Once done you'll get a better result:

Last Edit: June 23, 2020, 05:58:53 am

This is much more helpful than i was hoping for :3
thank you kindly for all the effort
this problem had been bugging me for a long while and google was not exactly being helpful
was honestly thinking it had something to do with blenders triangulation since the main bulk of the errors apeared after triangulating

again. thank you so much for the help :3
its good to know what i need to fix >__<