Author Topic: Complex Objects Expand when rendering using Arnold and Substance Materials  (Read 1016 times)

When I render any objects in Maya and use Arnold as the renderer (For GPU Support) and Substance for texturing the object in the render has expanded for no reason.

I even tried rendering in Cinema 4D with the standard renderer with Substance and it stays normal until the animation starts.

89 seconds into animation:

90 seconds into animation:

If I use normal Arnold materials it is fine but as soon as I use the ones that the batch import creates it causes the whole object to expand and look bad.

 Am I doing something wrong or is this just a bug? I really want to render it out as I have been working on this over the past two years as I got more ideas to add to it and I don't want my work to go to waste (Yes I know it should not have taken two years to create, I had to recreate the who project because I made a huge mistake on the first revision and I only worked on it as creativity struck.).

This looks like it could be due to the displacement on the object. Does the applied material have anything hooked into the displacement node, what does the hypershade graph look like?

It seems strange that it would happen so far into the animation though.
Cg Artist @ ILM London

On the Substance side of things, there is a base color, normal, roughness, metallic, ambient occlusion, and height node.

I figured the height node is the displacement setting as I don't use Substance that often. What should it be set to? Also here is the HyperShade window

All of the objects listed (The displacement objects are linked to the height maps

The material graph

Also sorry for the confusion on the animation the movement does not start until 90 seconds into the video but it is weird how Cinema 4D handles it differently, Maya does not have the animation as it did not have the tools for the animation I wanted. I also attached the sbs and sbsar files, if the screenshots aren't good enough. Thank you for your response.

So looking at the material it seems the height/displacement is indeed the problem here.
In substance your height node is set to a value of ~0.7.

Anything above 0.5 will push geometry outwards and anything below 0.5 will pull it inwards.
So the 0.7 is pushing all of the geometry the material is applied to out which is why youre getting the strange bloating effect. I get the same result if I apply this shader to a standard cube.

You can fix it by setting the height in the material to 0.5.
You can also disconnect the displacement node from the displacement shader slot in maya (attached image).

Im not sure how Cinema4d is handling displacement as each renderer tends to have a slightly different setup but generally if you set the value to 0.5 it should be fine.
Cg Artist @ ILM London

Thank you for your help. I got all of it worked out now. In the end, I just removed the height-map on substance designer since I don't need to modify the displacement. The only reason why I mention Cinema 4D is that I use it for animation since Maya does not have the tools I need and render it out there. Here is my work with everything working, this is only the model but I will start animating soon, I added some other things while in the process of reworking the materials.