Author Topic: Substance Designer 2020.1.2 Very Very Slow  (Read 1635 times)

Specs: MacBook Pro (Retina, 15-inch, Mid 2015), 2,5 GHz Intel Core i7 16 GB 1600 MHz DDR3 AMD Radeon R9 M370X 2 GB Intel Iris Pro 1536 MB

I've read similar posts, e.g. that suggest that "Updating Library..." should be run once and for good.

However, I've left it running overnight, tried reinstalling, removing local user files, etc — none of these work. Just starting a new empty graph, pressing space and trying to type triggers "Updating Library" and renders the whole machine completely frozen (I/O must be OS-level synchronous or similar since I can't even switch to another app during this frustrating process). In any case, once the first "wave" adding new node results in a similar issue — and no, it doesn't seem like it's updating anything in background judging from Activity Monitor.

Please help!

Anyone has any ideas?

Why does the Library keeps updating all the time? Even more, why does it need updating on completely fresh install? What does SD update it from/to?

Just to make it clear: this is a pretty serious bug that pretty much prevents me from working on my Mac.

Also, Windows version seems unaffected. On Mac it only started happening recently after updating to 2020.1.2. It used to be fine a couple of month ago.


Thank you for reporting this issue. Indeed, this appears to be highly disruptive.

I will investigate this behaviour on a MacBook Pro and get back to you with the results. I appreciate your patience!

Best regards,
QA Analyst
Substance Designer Team


Thank you for your patience, I was unable to reproduce this issue with a MacBook Pro on macOS High Sierra and an Intel Iris Pro iGPU.

The Updating Library... message, in most cases, means the thumbnails are being rendered. These thumbnails do not exist when the application is first installed and are generated when they are displayed the first time. Past that point, they are reused for all future sessions if their source content was not changed in the meantime.

The rendering is performed on the currently selected Substance Engine (OpenGL by default which is run on the GPU if one is available).
Please note a number of MacBook configurations do not include a dedicated GPU, and instead use an Integrated GPU (iGPU). This means the CPU needs to share power with its iGPU, which can slow down the entire system is a very intensive task is performed on the iGPU – such as rendering a graph or all Library thumbnails.

Let us try to reset the Library thumbnails database:
  • Close Substance Designer
  • In the system bar, hold the Alt key and click on the Go menu
  • Select the Library option
  • In the new Finder window which was opened, go to the following location: Application Support/Allegorithmic/Substance Designer
  • Delete the databases folder
  • Open Substance Designer and create/load any project
Please let me know the results of taking these steps. Does the Updating Library... message clear after the thumbnails are generated?

Thank you for your patience and help!

Best regards,
QA Analyst
Substance Designer Team

Hello Luca,

Thank you very much for getting back to me about this issue.

First, to get this out of the way: I'm using MBP"15 with AMD Radeon R9 M370X 2 GB in addition to the embedded Intel Iris Pro 1536 MB.

As far as the resetting thumbnails go, as I've mentioned in the beginning of the post, I did remove the entire `~/Application Support/Allegorithmic` directory before re-installing the Substance Designer.

I am also experiencing very serious system-wide lags directly at the startup of Substance Designer and they seem to be re-occuring later when I'm working. So I'm not even sure that "Updating Library..." is the actual cause and not just something I'm anecdotally stuck with when the lag occurs.

I've tried to record a video of my screen, but as I expected, this didn't work well because screen recording software is also quite demanding on the GPU.

Is there any way you can force rendering on non-CPU or, say, limit the number of cores being used?

Again, thank you very much for your help!

So finally find time to do what you have suggested; I've removed the thumbnails database and, as expected, they had to be regenerated on next start. The app still freezes during that process (the impact is very, very significant, I had to wait for good 15-20 minutes to have the bottom of "Noises" generated).

More importantly, it's not only Substance Designer app that freezes, it's the entire system.

One other very important fact: the "Updating Library..." is not the only place where freezing occurs. It definitely freezes for 30-60 seconds right when the application starts, then randomly when projects are being open — and definitely each time when you hit Open and native OS Finder dialog shows (freezes for more than a minute, a couple of times, then goes back to normal).

Again, the freezing affects the entire system. I'm 99% sure rendering/hardware is not a bottleneck for a bunch of reasons (i.e. the machine runs some pretty heavy AAA games, is able to render complex scenes both on GPU/CPU, does some pretty serious compilation tasks in parallel with sharing screens and video calls, Substance Painter works perfectly, etc, etc) — besides all the nodes render just fine, and, as I previously mentioned, previous versions used to work fine (on this particular machine, since 2017).

This has to be some OS-level call or similar. Based on the symptoms, it _feels_ like it has something to do with file system access — but just in case you'd suspect my SSD, I've ran diagnostics on it as well, and it's completely fine (besides, there's a very slim chance that only a single application would have been affected by a faulty SSD, consistently, even after all the reinstalls). I cannot completely eliminate the OS update as a factor, because I honestly don't remember when I've updated it last time and whether the problem started occurring after that or not. But this has to be something between SD and macOS (the same SD version on Windows works perfectly fine).

I'm running macOS Mojave 10.14.6 (18G103).

PS I've attached a screenshot taken _after_ ~10 minutes of waiting between "Updating Library..." events. You'll see that stats are not even sampled properly by Activity Monitor (and I couldn't switch to any other application either, the entire system is pretty much frozen by SD) as it clearly took a lot more time than what was shown on a spike.

Really hoping we can get to the bottom of this :fingers_crossed: