Author Topic: MacOS: starting Maya executable from command line crashes Substance on startup  (Read 1734 times)

I am an old school Maya user, currently using Maya 2018, and I'm finally seriously getting into Substance, but I can't get the plugins to load, they just crash Maya at startup on my Macintosh.

I like to start Maya using an Automator "alias" which in turn opens the old "Maya Terminal.term" shell which types in "maya -style fusion", which starts Maya in a "light" QT skin, which I much prefer over the dark scheme.

The problem can be easily replicated without setting up a Maya Bash shell and setting the QT startup skin options that I added with the Automator macro by simply opening up the folder and double clicking directly on the maya executable in the "bin" folder with the substance plugins loaded - maya will simply crash on startup when it tries to load the the problem is not caused by my preference setting the "fusion" QT skin flag in the terminal.

I'm running High Sierra on an old twin processor cheesegrater Mac, with the NVidia video drivers, and without the NVideo drivers, and the old ATI card that came with the machine - loading the Substance plugins and starting the maya executable directly, or with the terminal, crashes Maya either way.

I thought the problem might be caused by my other scripts and plugins, so I tried all this on a clean new Maya install, with all the default settings, and maya still can't start from the terminal, or double clicking on the maya executable directly within the folder with the Substance plugins loaded without crashing when they try and load.

I'm going to try and replicate this on another machine later tonight.
Last Edit: April 09, 2020, 06:44:39 am

I haven't seen this before, but it may have to do with the GPU engine failing to load on that old of hardware. Does Maya give you a crash report dialog? There should be a callstack in there which would be helpful.

Which version of the plugin are you using?

If using a newer plugin, you can try manually switching to the CPU engine, the plugin config file will be at ~/Library/Preferences/maya/2018/substance/substance.cfg
Then set EngineType to 1.
Last Edit: April 09, 2020, 04:04:24 pm
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

Setting the EngineType to 1 did the trick.

Note I'm running Maya 2018, not 2020. And the hardware is old, but not THAT old, lol, it is a Mac Pro 2009 with the ROM update and a NVIDIA GeForce GTX 750 Ti, it was fully supported by Apple up to the last couple of updates to MacOS ie it lost offical Apple support with the release of Mojave in June 2018, so it is officially only a couple of years out of date.

I only tried it on the old ATI card that came with the Mac when the newer NVidia card failed to load the software.

I just tried installing the same Substance plugin - Version 2.1.0 - (which is the only one for Maya 2018 that I see to download on your current website BTW) on an early 2008 27 inch Imac, that also is limited to running High Sierra at the latest, and the plug failed to load in exactly the same way when I started Maya using the command line or double clicking directly on the "maya" executable in the hidden "bin" folder.

And I also tried running the QT "-style fusion" flag under Windows 10 by adding it to an alias used to startup Maya 2018, and the Substance plugin loaded fine, so the problem is not with the alternative QT "skin" but with starting Maya 2018 on MacOS using the raw maya executable or the command line with the renderer for your plugin set to GPU....

Thank you! At least it is running now, but maybe there is a way to fix it so I can run Maya from a command line start, and still have GPU running in your plugin on my GeForce GTX 750 Ti which I've found to be a reasonably fast card for 3d production work .....
Last Edit: April 09, 2020, 04:47:55 pm

I think it isn't just the hardware, but MacOS. I don't remember what version of MacOS that newer OpenGL was supported on, but for the longest time OpenGL 2 was the only thing supported.

The GPU engine requires at least OpenGL 3, possibly OpenGL 4, so it may just not be able to work without an upgrade to the OS or machine at this point.

The OpenGL 2 version of the Substance Engine has been deprecated for a while now, since before the 2.0 plugin release I think.

I did change the path to 2018, I forgot to edit it after copying the path I was looking at.
Last Edit: April 09, 2020, 06:27:41 pm
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

Thanks for the quick reply, but with respect, your reply makes no sense, although it sounds very impressive, lol.

As I said in my original post, the plugins load fine (without first manually setting the CPU flag as you explained) if I double click on the Maya app icon like most people would, they just fail to load and crash the program if I launch Maya 2018 from a mac terminal command line, or by double clicking on the "maya" executable hidden within the .app/bin folder.

There is a bug in your code, it is not a MacOS hardware or software problem, because your software works fine if I start Maya on my "old" setups like most people would, but, as I also said in my first post, the reason why I prefer to start Maya on my Macs with the terminal is that it allows me to change the QT skin on the Maya interface to a "traditional" light style, rather than the light text on black that is currently in vogue for many.

(On windows it is possible set startup flags in an app alias, so that's how I do it there.)

Incidentally, other Adobe software, and Blender, gives me the option to set a "light" interface style, I would like it if the Substance family had that option also. I'm not a big fan of reading light text on a dark background, it makes my eyes tired.
Last Edit: April 10, 2020, 01:25:37 pm

I did manage to repro this, for some reason it doesn't like loading the GPU engine with Maya 2018 when started that way. It oddly doesn't happen on 2017, 2019, 2020, etc., so I'll check it out later for the next release. As there's already another small patch release planned for next week, we can look at fixing it for that.

I'll have to look at if somehow it just isn't loading, or whether something is messing up the filepath somehow.

As a workaround until then, is it possible to set the Fusion UI flag through environment variables in the Maya.env file?

As for the light/dark theme, that is something each team would need to look at, and would be better proposed in their respective forums as a request. It's easier for them to keep track of it if directly sent to them rather than through indirection.
Last Edit: April 11, 2020, 04:31:55 am
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries