Author Topic: Viewing Substance Source materials - previews broken  (Read 1803 times)

Trying to browse source through the launcher again today. It was working again recently, but was slow due to internet being slow because of COVID.  However, today I noticed that the previews are not loading at all.  It just displays a little broken image icon in the top left titled "preview".  It's doing this on all materials on Source trying to browse them through the launcher.

I just wanted to add that this is happening to me as well.  Tried completely uninstalling Launcher and reinstalling but this does not fix the issue.  Looking for a solution.


Sadly we are aware of this issue, we are trying to find a solution to resolve it as soon as possible.
In the mean time you may use the website if you need to make any purchase, the broken previews seems to work fine on the website :

Just want to add that I am also seeing this issue, but it sounds like the dev team are aware of it 👍

Hello !

Just to let you know it should be fix with our latest version 1.5.2 (released yesterday) !
If you find any other weird behaviour do not hesitate to let us know :)

Thanks !

I am experiencing this issue as well.

I am running 2020.1.3

The issue is indeed back, should be solved (again) in 1.6.0 release this summer ! ^^
Hopefully should be a definitive fix this time !