Author Topic: Alchemist 2020 no displacement and other issues  (Read 1430 times)

Just installed the Alchemist 2020 patch.  Since then, the interface has been sluggish and sometimes nonresponsive.  I am able to work around that by trashing the app data in "roaming".  However, that means I have to re-import my source library again and start that whole process over which takes 10 minutes or so at least.

Anyway, what's bothering me currently is that the tessellated displacement has completely stopped working.  It was working yesterday and this morning, but now it just doesn't work at all.

I've tried updated Nvidia studio drivers and still no luck.

I've checked the global tessellation/displacement settings as well as the height range and height position in my layers.  Nothing changes as I move the sliders.

Here is my log file:


So I started over by creating a new project, and now tessellated displacement works, and is no longer non-responsive.

What's going on here?

Hello,

In the Channel settings panel, is the height channel activated?
In the Viewer Settings, in the Shader section, is the displacement value set to Tessellation?

Can you send a screenshot of the viewport with a default material like cliff rock with the displacement amplitude set to 0.3 and displacement quality set to 1?

Thanks
Substance Alchemist Product Manager

 

So I reopened the project that was giving me trouble.  All of the channel settings were off except base color and normal.  Which is very strange as I started out with a fresh install of Alchemist and this was the first project I tried to build with it.  I never touched those settings.  (I didn't even know they existed!)

So maybe the first material I dropped into my layers didn't use anything but diffuse and normal?  And the project assumed those settings?  I don't know how else they could have been toggled.

Anyway, that was the problem!  So at least I know where to look now should it happen again.

As for the non-responsive interface, I'm still working on a repeatable procedure that causes it.

Is there a chance that some of my stored source materials are no longer compatible (like maybe they've been updated for the newer engine, but I'm trying to use old versions...would that be an issue?)

Do you remember which material you dropped in the first place?
It should not affect these settings, only the user can change them. That's why your case is really weird.

What part of the interface is not responsive? The Resources panel?

All the Source materials should be compatible. When we upgrade the engine version, the compatibility is maintained.
Substance Alchemist Product Manager

When it goes unresponsive, it's the entire interface.  If I try to click anywhere, the whole screen grays out. 

I was able to reproduce it just now.  I start with "cliff stylized mossy" then I drag a water filter over it.  It takes 25 seconds for it to update.  If I try to do anything (clicking anywhere on the screen) the whole screen grays out and slows the process even more.

Once it has processed, I'm able to move sliders on the water and it is real time.

Is this normal behavior?  Maybe I just need faster CPU? 

I think the initial problems with unresponsiveness I was having had to do with the library building along with this issue I just mentioned happening at the same time...so it was taking 10 to 15 minutes for the app to respond.

Now we're down to about 25 seconds in this simple scenario...so if it's normal, I'll just learn to live with it.

OK - I was able to test with a friend using the exact same materials and process...his viewport updated in only about 8 seconds.

Time for a new PC on my end.  I think for now, this can be considered solved.