Author Topic: Installing Substance Plugin crashes Vray in 3dsMax  (Read 960 times)

Hi everyone, this is driving me nuts:

I have tried with 2018, 2019 and 2020 versions of 3dsMax, Vray and Substance plugin.

I install 3dsMax and then Vray. When I change the renderer to Vray it works no problem.
I install Substance plugin. I try to change renderer in max to Vray, it crashes 3dsMax.

The only version that Substance did not crash is Vray RT in Max2018!!!

My computer specs are:
Intel Core i7-9750H
16 GB RAM
512 GB SSD
GeForce GTX 1650 MAX Q, 4GB GDDR5

Please, I need help with this. I don't understand why is crashing.


Hi, I've just reported a bug that is possibly related, including a fix.  Please see https://forum.substance3d.com/index.php/topic,32775.0.html

Yes!
Thank you, it works. Just changed pymxs.rt to pymxs.runtime in SubstanceRendererCompatibility.py

Cheers

This is fixed now and will be in the next patch soon.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

Hi Guys,

Once I installed the substance plugin and try to put Vray as my render engine in 3ds max 2019 this message "attributeError: 'module' object has no attribute 'rt'" appears in red and causes 3ds Max or crash or closes by itself. If anybody had this situation before hope will let me know how I can solve this problem. I am pretty sure that the problem is caused by the substance plugin because it appears as soon I installed it and disappears as soon I uninstalled it. I already try to reinstall 3ds Max 2019 (clean way), Vray, all the plugins, everything, that is why I know is the Substance plugin. 

Thanks in advance.PS: I have a video that shows the problem. I will gladly send it to anyone who wants to see it. Attached I sent an image.

Regards,

Hi guys,

        I did what redshift_geoff recommended (thanks) and it seems I move a step forward, besides now a pop-up window appears (I saw this pop-up window in other posts in the forum) when I try to set up my render engine (image attached). If I click cancel or apply nothing seems to happen but the UVW Map or the Unwraps I did for Substance Materials did not render well (they do not keep the scale). In the viewports, they look good (as supposed) but in the render don't.

        Let me if you have a solution to this problem or any advice. Thanks in advance.

Regards,