Author Topic: Problem with plugin and Unity 2018.1  (Read 1495 times)

Hi, I have a project in Unity 2018.1.9f2 that I can't upgrade at present (due to other unrelated Unity changes). The substance plugin was working fine until recently but then started rejecting my login details (which still worked fine on the website). I deleted and reinstalled the latest version of the plugin and that fixed the login problem however it now won't download the substances correctly (seems to stop at 3% and just leaves a unreadable .sbar file in the material directory).

I can work with the plugin with 2018.4 but this is no use for my current project.

Any help with this would be much appreciated.

Hi, I have a project in Unity 2018.1.9f2 that I can't upgrade at present (due to other unrelated Unity changes). The substance plugin was working fine until recently but then started rejecting my login details (which still worked fine on the website). I deleted and reinstalled the latest version of the plugin and that fixed the login problem however it now won't download the substances correctly (seems to stop at 3% and just leaves a unreadable .sbar file in the material directory).

I can work with the plugin with 2018.4 but this is no use for my current project.

Any help with this would be much appreciated.

2018.1.9f2 is unfortunately no longer supported by the Substance plugin. We are focusing on the newer versions of Unity and trying to keep up to date with Unity's editor changes. Sorry for the inconvenience this causes. :(

The asset store claims that you support 2017.3 and higher.



Your website here states you support Unity 2018 and Unity 2019:

https://docs.substance3d.com/integrations/unity-170459323.html

So what versions do you actually support, if these resources aren't correct?

This seems like a serious problem. Remember that Unity's Asset Store doesn't allow people to download older versions of assets. So, if a previous version of the plugin was working in 2018.1, and you push out an update that breaks it, there's no way anyone can download an older version of the plugin via the asset store. Asset developers generally ensure that their assets are compatible with many versions of Unity for this reason, using precompile directives. Are you guys not doing that? Are you just letting older versions of Unity fall out of support with the plugin?

Hi,

I want to apologize for the lack of guidance on the supported versions. This is our fault and I take responsibility for this miscommunication. We need to make sure our docs and asset store are updated to reflect the versions we are supporting and this has not been the case. 

The plugin is constantly evolving to keep up with the Unity updates and API changes, so we are needing to set specific versions we support. This is not a Unity issue but something we should be doing correctly as we release content on the asset store.

Here is what we have for official support. For the 2.4.4 plugin (current release on asset store) we support Unity 2018.3.x and higher. We are working on the next asset store release (2.4.5) which will support Unity 2019.3.x and higher.

We have support for specific versions because the plugin relies on API changes in Unity to function properly and to provide a more stable plugin. I apologize that we haven't communicated this information clearly. This is a fail on our part that we will address.

With the upcoming 2.4.5, we have 2019.3 and higher as this relates directly to a new API that unity added to query the HDRP pipeline asset. We need this API to correctly set the plugin mode for when the project is using HDRP pipeline asset. Our official support for HDRP will be with 2019.3 and higher.

I started the update to our docs and when we have 2.4.5 released I will add more info about our official version support for HDRP. We are also going to make sure that legacy packages are not appearing on the asset store.

Thank you for your support and feedback. We will address this issue.

Cheers,
Wes


Last Edit: March 10, 2020, 03:29:03 pm
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

Your 2.4.5 release will support 2019.3, or require 2019.3? I assume that you're not saying that as of 2.4.5, the plugin will no longer support 2018.3?

Your 2.4.5 release will support 2019.3, or require 2019.3? I assume that you're not saying that as of 2.4.5, the plugin will no longer support 2018.3?

The new version 2.4.5 will be our official support for HDRP. It uses an API that Unity added in 2019.3 that allows you to properly query the render pipeline asset that is set for the project. However, 2.4.5 will also support 2018.3.14 and higher as well. The HDRP implementation will work as it did in the 2.4.4 plugin for versions previous to 2019.3.

We only set a minimum version for Unity when there has been a major API change in Unity that we support for the plugin. 

Cheers,
Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

Thanks for clarifying. That all sounds reasonable, given that HDRP only officially comes out of "preview" with 2019.3 anyway.