Author Topic: Tablet Issues after 2019.3.x update  (Read 63328 times)

Hello Allegorithmic,

I like to reply to this thread. I know probably some of this has been said before. But I'm really frustrated using Painter recently. I used to love it and that love starts to deteriorate. I use the most recent version of painter, which is called 6.2.0-513 for some reason, and I noticed since a few versions ago, I think it was 2019.3, layer slider behaviour got a really annyoing trait. Each time when I slide the slider to zero, it is stuck there and an attempt to slide it back to the right simply wont work in one go. I have to reclick the slider before it will move again. Layer blending has become super cumbersome for me ever since. (I mean the slider that is under the blending mode on each layer and that gets exposed on user click.)

Generally, getting around the UI with clicking and sliding has become a lot more unresponsive with hits and misses or getting stuck inbetween. When selecting an integer or float value in any field with pen, Windows Ink writing promt pops up and there is no way to conveniently change values that where selected with pen by keyboard anymore. I feel those things are regressions to older versions.

These things alone don't seem like much, but they really add up interrupting my workflow. I was used to SP working flawlessly in the past and ever since 2019.x, with every new version, I feel a new quirk gets introduced, while the old ones won't get fixed. Please get the basic functionality solid before upspicing SP with new features. I felt this always was a separating factor between Allegortihmic software and other software. I'm really worried now that these seemingly tiny things get overlooked and that there is more weight on keeping SP more marketable and on par with recent developments in other software than on providing solid and flawless tools. I really don't care about fancy RTX bakers, UV autounwrapping and stuff if my wacom pens (I have intous 4 and 5) with I which I worked flawlessly for years in Painter, suddenly bit by bit start behaving more and more unworkable.

Update: I followed your guide and adjusted my pen settings. If everyhting works now, pardon my frustration. I'm hoping to be able to work again like I am used to with these settings adjusted to your recommendations. I feel like this should somehow be shown as a default setup prompt with step by step instructions when first starting the program. I guess it would save a lot of people the hassle and frustration of first having to search the forums and lose their faith in proper functionality of Painter.

Update 2 Following the guide and adjusting the windows ink settings really did it. Very glad to say it's working again as it used to! You guys should really include this as setup instructions integrated into the program, or simply hint to the page in the docs at first start. It would save a lot of users the frustrations I think. I mean I worked like this with all the pen quirks like for weeks or even months before I found this out. Was losing my faith in Painter, it was a really destructive feeling to have to work like this and to think that this is now how it is. Substance Painter love rises again (never really left... ) What a relief.


Last Edit: July 26, 2020, 12:25:09 pm

I downloaded V 6.2.1-529 today. Unfortunately, zooming behaviour with pen is still really disruptive for me. It seems that occassionally but regularly, while zooming, the application loses its context for a moment, which causes zooming to be interrupted. I see that the program bar on the top of the screen gets white when the zooming interrupts.

All other problems with the sliders seem to have disappeared for me after adjusting windows ink to the recommendations. But working with zooming behaviour like this feels really annoying unfortunately  :-\ It works flawlessly with mouse but that does not help in any way.

Seems I am forced to revert to some older versions for good now, as I need to do work without constant pen glitches while navigating. Pity. I ask myself if this means if I have to live with this now after the addition of windwos Ink, if I wanto use the latest version of substance painter. It seems unbearable to me if basic functionality just glitches.

Update: It's really weird, as soon as I report something, it seems I was wrong :P . Now I reverted back to V 2019.2.3, and the zooming behaviour peristet for me. So pardon me blaming it on the latest versions. I just don't get it, i never had problems in SP in the past and now I am more error hunting than working ... Gotta check what's causing this. Makes me crazy.
Last Edit: July 30, 2020, 07:36:59 pm

Another version, and still the same issues? Sliders dont work properly, sometimes getting right click circle when trying to move the slider handle and they dont update for a considerable deadzone around the click point (see my previous 2 gifs). Also, the intrusive Ctrl+alt+shift bubble that pops up seems to be impossible to disable...i've tried everything. it's a "feature" i've hated since windows added it. I think i know what keys i'm pressing!

Could a developer please explain why they have completely dropped support for wintab when it's easily the best solution till you can figure out how to fix your windows ink support.

Again, reverting to wintab version until this is resolved. I wonder how many years it will be till windows ink versions are usable. Already 1 year down.

Edit: and yes, i went through the configuration guide again, for probably the 10th time. and the issues persist
Last Edit: August 01, 2020, 07:57:21 am

Think I'm having the same issue as other people, when using my wacom cintiq 13HD tablet with pressure sensitivity my brush strokes lag.

I've tried all the recommended settings in pen and touch etc. but no luck.

Such a shame since this is my first month subscribing...

I can't believe I'm now dealing with windows ink on Painter after years of being frustrated with it on Photoshop on a Wacom Cintiq.

Trying to paint in this is so frustrating now. Followed all the guides and removed as much as possible but...

1. That annoying ring on every right click.
2. Text everytime I press ctrl, alt or shft
3. Every slider lags out and colour pallete lags for a few seconds everytime I drag the picker.
4. Also sometimes clicking on another layer doesn't register.

Please for the love of god sort this out :)
Last Edit: August 13, 2020, 07:50:21 pm

Just chiming in with a desire to get wintab back :D

I get all the kinds of weirdness people are describing with windows ink, particularly performance stuff, and I've been up and down the tips and documentation. While I'm sure re-implementing wintab is a pain in the neck, as people have pointed out it really does work rather painlessly in other software packages.

Painter has too much awesomeness going for it to let it be hampered by windows ink :D

Windows Ink is akin to a weed, that is only there to disrupt a workflow and cause rage inducing frustration at every circle, ripple and delay. Set root after each OS change that is a nightmare to ferret out every little toggle to stop every little hindrance.

And you suddenly make this mandatory for tablet use?

This might have been an acceptable inconvenience when you were the only fish in the pond, but there are competitive alternatives out there now. It makes no sense that you would implement a "feature" that only damages your product at this point.

"A good artist will manage with what's at hand, but a good artist will not pay extra for inferior tools" -some muppet somewhere probably

Hi Froyok,

Hope you're doing well.  I am having problems with my display tablet in Substance Painter.  I have followed all recommended settings in the documentation, and simply cannot get pressure sensitivity to work at all.  Pressure sensitivity works in other applications including Photoshop, ZBrush, Krita, and Affinity Photo, so I know it isn't a hardware issue.  Do you have any other suggestions?

Huion Kamvas 22 Plus
Driver version:
Substance Painter 2020.2.1 (6.2.1)

UPDATE: So after many attempts, I finally got pressure sensitivity to work in Painter.  First I rolled back to version 2019.1.2 and that worked fine.  So next I tried reinstalling the latest version and it was broken again.  Finally decided to do a Windows system reset, restore a previous drive image using Macrium Reflect and try again.  After performing Windows updates, updating all my apps, and redoing the recommended Windows Ink settings everything works fine--Painter, Mari, Photoshop, Krita.  The only app that doesn't work is Sketchbook.  I got luck somehow.  Any idea what the issue was?
Last Edit: September 26, 2020, 09:42:24 pm

Heavy in production now, and this freaking white circle.. it just won't stop. It drives me crazy.
Also, the sliders got worse-I did not change a thing. Maybe Windows update cleared the reg changes.
All Pen settings are like recommend by Substance-.
I won't get rid of that damn white circle., that's such a pain!!
Does Substance finally have a guideline for Cintiq users?

And my specs are here:
Iam on a Cintiq 27QHD DTH DTH2700 ,
Drivers 6.3.38-2 - so slightly newer then the ones you test with.

Windows Ink should be removed from existence, im in production now and i was painting on a layer and all of a sudden it became slow and lagging like hell, if i turn off windows ink it runs smooth but no pressure, Zbrush doesn't care about windows ink whether it's on or off pressure is still working. Using a 10 year old Wacom Intos 4 tablet, latest drivers.

Wacom One
Driver 6.3.41-1
Windows 10
Painter 2020.2.1
All settings are configured as per the OP

Issue -> No pressure sensitivity.  Note: This is not my primary monitor.

- Explain in details the problem
The right click circle still pops up when in substance painter. I followed the "Configuring Pens and Tablets" documentation from the website. No luck. I turned off "press and hold for right-clicking". I do have windows-ink enabled.

- Provide the model, brand and driver version of your Graphic Tablet
Wacom DTK-2100 2nd Gen   

- Attach a log file to your post, see:
Log attached

I have major lag issues navigating the viewport when Windows Ink is enabled. If I move the pen very slowly, there's no problem, but as soon as I move faster and work as I'd normally, the lags make working a real drag in productivity. I've followed all recommendations from the troubleshooting page regarding Windows Ink and Tablets, but found no solution to this problem in particular. If I disable Windows Ink, there are no more lags, but I have no pen pressure. So I'm stuck with the lags for the moment in favor of having pen pressure.
I had this issue both with my prior Wacom Tablet and still have it now that I'm using an XP-Pen model.

Tablet: XP-Pen Deco 01 v2
Driver version:
OS: Windows 10 20H2

My issue can be seen in the attached screenshot. The pen pressure works to some extent but the difference between high pressure and low pressure seems very low.
Left stroke in the image: Low pen pressure
Middle stroke: Full pressure
Right stroke: Using the mouse

As can be seen the difference between low pen pressure strokes and full pen pressure strokes is quite low.
In other programs like Krita the pen pressure works completely fine.

My Tablet:
Gaomon M106K
Driver version

Is it really so hard to add the option to disable Windows Ink?  >:(
Since version 2019.3.0, the pressure sensitivity does not work for me. My tablet is old and doesn't have Windows Ink support.
My tablet: Penpower Picasso, driver v5.03 (2015/09/14)