Author Topic: Normals blending between the stamps is odd  (Read 138 times)

Reproduce steps:
- open MeetMat sample scene with paint layer
- pick any material from default library (I used Iron Diamond Armor)
- enable nrm channel in material settings
- increase the brush size and draw a single large stamp
- decrease the brush size and draw a small stamp on top
- observe that inside small stamp all other channels are replaced, but the normals are mixed, giving the material unwanted "transparency" effect..

Is this a bug or design? It's impossible to paint layering scales or fur like that..



There is a way around. You have to do following steps:
- in the texture set settings, add User0 channel (RGB16F)
- in the paint layer material, enable User0 channel and disable nrm channel
- in the paint layer channels mapping, set User0 to "normal"
- add Anchor Point to the paint layer
- create new fill layer
- in the fill layer material mode, select anchor point created from paint layer
- in the fill layer material, enable nrm channel and disable all other channels
- in the fill layer channels mapping, set Normal to "User0"

After this setup, normals behave as expected, allowing to paint on top. Shouldn't it be like that by default?



Am I missing something? Is there a magic checkbox somewhere? An easier way?

Last Edit: January 24, 2020, 11:34:14 pm

up!

This is by design, currently stamping normals will combine it with the information below the layer. We don't have a way to control this blending mode per stamp for now.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.