Author Topic: Designer to Painter material export problem  (Read 185 times)

Hello, I made a simple material in Substance Designer (see attachment). When I publish .sbsar and import into Painter as a base material, there's a problem. When I try to paint it with a brush, it looks awful. Seems like it uses default resolution of 256x256, despite I set everything to relative to parent and exposed output size and random seed. Painter project is set to 2K as well.




Only If I force output size in designer graph to 2K absolute, everything looks fine.




Should't it work like that in relative mode? What am I missing?
Last Edit: January 21, 2020, 01:50:06 pm

Any help?  :(

Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

Please attach a log file : https://docs.substance3d.com/spdoc/exporting-the-log-file-128745475.html
Material in original post was set to absolute, so I set it back to relative and reuploaded source files and logs.
Last Edit: January 21, 2020, 01:51:26 pm

So I gave a try at your Substance file and everything works fine on my side. With the graph set to relative to parent the leaf/scale is giving the right result in Substance Painter.

Something to know, is that a Substance graph inside the material slot of the brush tool will be generated at 512. It's only when the resource is used in a fill layer or as stencil/projection that the resolution will be higher.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

Something to know, is that a Substance graph inside the material slot of the brush tool will be generated at 512. It's only when the resource is used in a fill layer or as stencil/projection that the resolution will be higher.
Ok, thats what I though. The problem is in waveform node. It is based on 1024 samples. I found that if samples number is 2x higher than the resolution, waveform pattern breaks.

1023 samples, everything's fine


1024 samples, separated lines.


Looks like a bug to me.

I suggest to report it in the Substance Designer forum then.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.