Author Topic: Substance Source Not Allowing SBS Download  (Read 3226 times)

I'm clicking on the assets that have both a SBS and SBSAR file download, and toggling the download to SBS--but it's not downloading the SBS file...  Any ideas why?

Edit:  I have tried this now on two different computers and three browsers (firefox, edge, chrome) to no avail.  SBS files cannot be downloaded.
Last Edit: December 21, 2019, 07:35:44 pm

I am having the same issue. Multiple computers, multiple browsers. But unable to download SBS.

I can't dowload SBS and SBSAR, tested in multiple browsers.

Same issue, and tried, 3 browsers/

I was about to make a post about this.. glad its not only me..

yes devs we are doing it right, I have used Substance since day 1. we hovered over to get  the different formats, SBS, or SBAR does not work on hover..only when you click down load  with out hover does Sbar work.,..

So right now we can't use SBS formats at all...Which is upsetting since I only use....SBS check out how some are made.. for learning process... So right now source is useless to people like myself...

I hope this is fixed soon. thanks.
Last Edit: December 22, 2019, 05:15:56 am

Exactly the same problem. Tested on Safari, Chrome and Firefox (Mac). Pic attached.

Only the Download button in the general thumbnails works (but it doesn't download the SBS, nor MDL. Only SBSAR)

And once you enter to see more details from material, the dropdown button to select SBSAR, SBS & MDL doesn't work at all.


Also a QUESTION: what that “pts” means at side of our user name? I was under the impression that “Indie Subscribers” had 30 downloads/month. And that “pts” seems to me something like “points”. Or what?

Cristobal Vila -

I am having the same issue also. Good to know others are having the same problem.
I have feeling that someone broke the link to the files to those buttons on the website because the sbsar link on the second menu doesn't work.

I am on a valid Indie subscription and was billed a few days ago, but I am still having 0 pts for downloads.
Do not know whether this is the same bug. Anyway I think they should give us some xtra downloads for
free to compensate this failure and our need to worry about it.

To @mailrox: if you enter to Substance Source through Substance Painter (instead of using a web browser) you can see your available downloads (I see there “24 AVAILABLE DOWNLOADS” instead of that confusing “24 pts”)

Cristobal Vila -

I my case, it still says 0 downloads. I also noticed that the recent so-called atlases are not shown in the Painter browser at all.
Looks like quite a bit of work left for the programmers early in 2020.

I'm having the same problem, can't download the sbs via the pop up, tried on multiple browsers. Can someone answer and solve the problem? Thank you

Yeah, same issue. Multiple browsers and the SBS/SBSAR option in the dropdown doesn't work anymore.

Cleared cache and all that.


@Alleg; to show this is not userbased..that you guys have the problem on your end;

SBS, MDL, and SBSAR from the secondary window download drop-up menu button;

Code: [Select]
(3Errors, 1 for each filetype: SBS, SBSAR, MDL)
ApiHelpers.js:47 TypeError: e.getDownloadUrl is not a function
    at ApiHelpers.js:33
    at c (runtime.js:45)
    at Generator._invoke (runtime.js:271)
    at Generator.forEach.e.<computed> [as next] (runtime.js:97)
    at c (runtime.js:45)
    at t (runtime.js:135)
    at runtime.js:170
    at new Promise (<anonymous>)
    at o (runtime.js:169)
    at E._invoke (runtime.js:192)
Last Edit: December 27, 2019, 05:32:14 am

I'm having the same problem. It used to work fine, now it doesn't. Tried 3 browsers.

It DOES work in substance launcher, so if you're desperate to get your SBS's while waiting for a fix, consider installing launcher. It's a pretty cool app - seems like a similar idea to adobe bridge, but, um, actually good.

Thank you, canary3d, that helped :)