Author Topic: [Solved] Is the UV mapping integrated in Painter 2019.3.0? How to run it?  (Read 5759 times)

Hi Subtance Team!

What are the pre requisite to automatic UV unwrapping to work.

I'm using Substance Painter 2019.3.0 and when I'm importing the mesh, the Painter automatic UV unwrapping look like importing the actual model UV mapping. I wish to use the automatic UV unwrapping.

How to force Painter to make an automatic UV unwrapping?

All my meshes contains a sort of UV mapping.
How to export without UV mapping is that posible?
Last Edit: December 18, 2019, 03:51:45 am

In this first version, the UVs are generated only if they are missing in the first place.

OK, for taking out the UV mapping from a mesh,
For example: open the mesh in Blender go to "Object Data Properties" > UV Maps select the UV's and press "-" to delete the UV mapping. Then export. Substance Painter 2019.3.0 will try to make an automatic UV unwrap.
Last Edit: December 18, 2019, 03:50:10 am

Did a quick test and works fine for small none complete models, i tried to import a model that had about 350 meshes to it and no UVs but did not work.

This is still in beta but i look forward to improvements on this had it will be super helpful for people like my self that work with CAD models and just want quick UV's

Hello,

  I am running 2019.3.0

I create a new project, select my mesh (without uv's) to import.
It gives me an error "Invalid Scene, mesh has no UV coordinates"

I have tried this with several mesh pieces.  Some directly exported from Zbrush and others exported from Modo.
Is there a step I am missing?  I see that by default the box is checked in the settings tab. 
 


Could you attach a log file please?
@DMAEuropa Any chance you could share that mesh with us for testing purpose?

Hey Jeremie,
   Attached the log file with 3 separate mesh pieces. 
Thanks for the quick reply.

The mesh unwraps fine for me. Make sure you haven't checked the Texture Set to UDIMs option in the New Project dialog.

Ugh . . . that's exactly what it was. 
(had the box checked for Texture Set to UDIMs)

Thanks for the help!
-Jeff