Author Topic: Alchemist 2019.1.1 Crash While Connecting to Local Disk of Source Materials  (Read 7000 times)

Upon opening 2019.1.1, I tried to link to a local folder of Source materials and the program crashed.  Log file was sent via email.

Hello msjphotography,
If you sent the crash report, then we'll investigate it. Is it something that happened just once, or does it crashes every time you link your folder?

Hi le Glaude.  Thanks for getting back to me.  I sent the report to Baptiste via email.  I've been having this issue ever since 2019.1.0 was introduced.  I submitted a bunch of info. to Baptiste right after 2019.1.0 was released with hopes that the issue would be resolved.  Unfortunately, it's still not resolved.  Here's what happens (and none of this occurred in 0.8.1 even when linking to the same folder).  I open a new project in .0 or .1, then try to link to a local folder of 400+ Source materials.  The program immediately crashes.  When I try to re-open the program, it crashes the moment I make or open a new project.  That's as far as I've gotten with Alchemist since the release of 2019.1.0.  I appreciate your help with this matter.

le Glaude, I'm happy to work closely with you to resolve this issue.  I really count on Alchemist for my living, so I'd like to get up and running as soon as possible.  Please just let me know what you need in order to investigate.

I think we have whatever we need. we'll have a look to your report and try to reproduce. I'll come back to you if we need more info. Thanks for your help.

Happy to send over my actual folder of Substance Source materials if this helps troubleshoot.  Last time I sent the list of materials, but that didn't seem to get the job done.

Ok, thanks. We'll try to see what we can do without it. If we can't find a way to reproduce your problem, I'll come back to you.

Hi msjphotography,

We just released alchemist version 2019.1.2 which should correct your link directory problem.

Please, let me know if problem persists.


Thanks so much for letting me know, le Glaude!  I'm on the road this week, but will give this a try as soon as I get home.  My fingers are crossed that this will work and I will finally be back up and running with Alchemist.

Hello,
i'm just gonna jump in the dialog. I have the same problem. Tried different solutions, from importing no subfolders and importing folder by folder, i always get the crash at some point. It is definitely a bug in the material loading.  After the crash i cannot reopen alchemist ever again, until i delete the material library file in the roaming folder.
I am using the newest alchemist version.

Oh and i don't get any error crash report, alchemist just dies.  :o

Just to be clear, runner2032, is this happening for you even with 2019.1.2 (the one that was released a day or two ago)?  I want to know before I go through the heartbreak of installing yet another version that just crashes.  Six straight weeks without being able to use Alchemist is killing my business.

Yes, this crash is happening with the latest version for me. The last version i used was the beta one, 0.81 or something like this, and this one was stable.

Yes, I found the beta 0.8.1 version to be stable as well, but since materials created in it are not compatible with the "non-beta" 2019 version, I'm in a no-man's-land until 2019 gets stabilized.  I'll install the 2019 version soon and let the forum know what the result is.

Hello,

I'm sorry to read this. runner2032, if you are on Windows, when Alchemist chashes, it actually says nothing. Crash report should appear next time you run it. Doesn't it ?

If you manage to send a report, be sure we'll analyze it shortly.
In the meantime, I'll try to reproduce on my side.

Regards.

Hi le Glaude.  I just installed Alchemist 2019.1.2.  When I launched it, the splash page opened, the "your license has expired" page opened (my license has not actually expired), then Alchemist immediately crashed.  I did not even get a chance to create or open a project.  At this point, I am more frustrated with Alchemist then I have been with any piece of software that I've used for over 30 years.  I have not been able to get Alchemist off the launch pad since it was released from beta.  Two updates have released, each one telling me that everything is fixed, and yet I still can't bill clients for work I'm supposed to be doing.  I have volunteered to help solve the problem, but Allegorithmic is not asking for my help.  Are you ready for me to help you solve the problem of should I just cancel my Substance subscription and find software that works?

My log file is attached.