Author Topic: Alchemist Immediately Crashes Upon Launching  (Read 9660 times)

I have not been able to launch Alchemist for a couple months now. I am running 10.13.3 Osx on a 2017 Imac 4.2ghz i7.
I have re-downloaded latest release and trashed old ones on my machine. I have emailed substance and never heard back.
Anyone experiencing similar issues?

I have the same problem. I'm desperately trying to open Substance Alchemist, but it keeps crashing at launch point. With the old version I was able to open the program. I have tried to re-install the program, launching it with/without Substance Launcher but it always crashes at the same point. See report. Please help. Thanks

Hello,

Can you try to delete the following files:
  • alchemistdatabase.json
  • createdMaterial folder
their location is:
  • Windows: ~/AppData/Roaming/Allegorithmic/Substance Alchemist
  • MacOS: ~/Library/Application Support/Allegorithmic/Substance Alchemist/
  • Linux: ~/.local/share/Allegorithmic/Substance Alchemist
Substance Alchemist Product Manager

Those two files are not on my machine. Before it crashing,  I see a window pop up very briefly saying that the program did not shut down properly. Any other suggestions? This is getting ridiculous as I have not been able to use this software for a couple months because of this problem. I have also reinstalled it a couple times and it did not help.

Hello,

Did you succeed to launch it at least once?
If yes, delete all files contained in this folder:
Macintosh HD > Users > [username] > Library > Application Support > Allegorithmic > Substance Alchemist

If you don't have any file there, it means something wrong happens during the install.
Substance Alchemist Product Manager

The crash-on-open issue hit me as well after I tried adding a library of substance source materials.   

I deleted and reinstalled several times, but still couldn't open the program, so I figured it had stored some corrupted info somewhere on my system.   

Anyhow, I found a solution to the crashing on startup (using Windows 7) and was able to get it running again.


Navigate to:

C:\Users\*user*\AppData\Roaming\Allegorithmic\

(keep in mind that \AppData is a hidden folder)

inside, delete the Substance Alchemist Folder

Then go to

C:\Users\*user*\AppData\Local\Allegorithmic\

and delete the Substance Alchemist folder there as well.


Once I did that, I was able to start up Alchemist as normal.

Hopefully it works for anyone else having this issue.

SIDENOTE:  The issue started when I loaded in a library of Substance Source materials that included a corrupted SBSAR.  I was able to locate the culprit by opening each one in Substance Player.  One of them caused Player to crash, so I deleted it and now everything is running fine.
Last Edit: January 20, 2020, 07:53:54 pm