Author Topic: PBR metal-rough shader is turning my layers green. Can anyone fix this please?  (Read 245 times)

Hi,
I am trying to put subsurface scattering on my character. From what I read, I can only get SSS by changing my shader Adobe Dimension to the shader PBR metal-rough. Every time I try changing it, all of my layers turn green. Could anyone help me fix this problem? I'm still a bit new to substance painter.

Please post your log file:

https://docs.substance3d.com/spdoc/exporting-the-log-file-128745475.html

Also if you can please post screen shots of what you're seeing, layers you have, any filters, plugins ect...

The first image is with the shader Adobe-Dimension and the second image is with the shader PBR metal-rough. The third image is my layers and filters.





Last Edit: November 25, 2019, 02:33:25 am

I can duplicate your problem like so...

I create an Adobe Dem project file, bake, and in a smart mat for Wood Ship Haul Old.



Then when I change the shader to PBR Metal Rough and add in any material it turns green.



If I toggle off the emiss from the fill layer or turn it off in the settings here:



No more green... This also happens if you have fill layers prior to going to PBR Metal Rough as those prior channels had Emissive by default.

I found it occurs by the emissive channel within a layer, fill layer, or material.

Try turning it to 0 so it's globally changed and then you'll know if that is your problem, as opposed to going to every layer and toggling it off. You can also remove Emissive from Texture Set Settings under Channels.
Last Edit: November 25, 2019, 05:36:07 am

Thank you so much! It worked!