Author Topic: Switching to 4K Causes App to Become Unresponsive.  (Read 5669 times)

Changing the resolution to 4K causes the application to become unresponsive.

Changing the resolution to 4K causes the application to become unresponsive.

Hi,

The GPU engine requires a robust GPU. We are working on optimizations, but we would need more information about your scene to know why it is becoming unresponsive. Please state your System specs.

Cheers,

Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

the latest release has seemed to improve the performance of working in 4k, but its still slow.  The cool thing about Painter is, you can work in a lower resolution, and then bump it up to 4k without losing quality.  Also, if you turn of the "paint in Height" 4k paints really fast.

SPECS:
PSU: Coolmax ZU Series 700Watt 80 Plus Bronze/ZU-700B
Processor: AMD A8-6600K APU with Radeon HD 8570D Graphics Black Edition 3.90GHz
Memory: Ballistix Tactical Tracers LED 8GB (May be Running XMS or AMD Profile mode, don't remember.)
Motherboard: Gigabyte F2A85XM-D3H w/ Multiple UEFI BIOS, Triple Monitor HDMI, Ultra Durable 4
OS Drive: Vertex4 SSD 128GB
Primary Storage: Hitachi 500GB HDD 7200RPM
Secondary Storage: Barracuda Green 2TB 64MB Cache 5900RPM SATA3
Full Profile Video Card: Gigabyte ATI HD5770 1GB DDR5
OS: Windows 8.1 PRO 64-Bit
Monitor: 46 inch Philips LED TV FTV
Case: Chietec Silver Scorpio T1/TX-10WD Full Tower Case w/ 17 Drive Bay, Full EMI Shielding, and High CFM Fans (Think it's 14 or 16 or more years old.)
Mouse: Logitech M215
Keyboard: Logitech K360

Special Note About Configuration: Setup using SATA3, Dual Channel Memory. If I remember correctly, I believe that since I'm using the ATI HD5770 with the APU and that board and Gigabyte brand the GPU on the APU is channeled for compatibility and to multiply performance by atleast 4 and operate as if you are running cards the built-in APU GPU and card in Hybrid Crossfire mode and with that memory, I don't remember the tech articles on the architecture. I keep all drivers and all other software updated when possible.

I've also got an Intel Quad Core 2 almost same configuration in a blue scorpio but it has a Galaxy NVIDIA GT220 1GB DDR3 in it and it's an Intel Quad Core on a Dell Inspiron 530 Motherboard and I think it's running a Raidmax Hybrid 2 RX-630SS I had planned on possibility running Substance Painter on to teach some people how to use it for painting, but I'm holding back due to the license limitation and incase I decide to get another APU setup like this one in a few years and transfer this one over. I think of the AMD build in a card ending in 50 = Low Profile (Not requiring power adapter and built-in power via rail is enough.) and ending in 70 = Full Profile (Requiring extra power adapter and higher amp rating to match on PSU.) when I think about it, or else the card doesn't get proper power, often overlooked.

So far following your tutorials on painting Hans it looks like this using 2048, when it is switched to 4k the bar stays around the beginning and doesn't seem to really move. I didn't add the Subsurface Scattering Emissive trick, veins, or some other things but it looks fine for the most part. Please excuse the graphics they're compressed and resized for web.
Last Edit: November 17, 2014, 11:16:21 am

Ok, I've tested it some more and here's my results:

Abyss (No Crashes and Supports 4K)
Cymourai (Crashes/Video Driver Crash)
Hans (No Crashes and Supports 4K)
Oceanus (Crashes/Video Driver Crash)
Custom Blender Sword Prop (No Crashes and Supports 4K)
Tutorial Hans Version (Crashes/Video Driver Crash)
Last Edit: November 17, 2014, 12:25:10 pm

I am working on a macbook pro, i7, amd radeon 6600/6700, win7 64

My problem is, if SP freezes, also my whole computer freezes. I can´t even start the task manager (ctrl + alt + del) and my mouse cursor disappears.
So I have to force a restart...

I do understand, that SP needs a strong gpu, but I would it expect not to freeze my whole computer + operating system.

Also, sometimes, when working with SP, I will get the message, that my GPU driver has been disabled.
Last Edit: November 17, 2014, 04:47:34 pm

Hi Michael,

When that freeze happens can you please send us the log?

Thanks!
Nicolas
Head of Product Management

Yeah, Michael and I should both send our logs.

Here's both the stats and the log files so you can see the information on number of crashes with the dates.

Also in the log file the Scene Creation doesn't match the text displayed for Scene Creation in the Substance Painter window.

And more recently I've noticed the number of Scene Creation can vary as last time it showed 3 times, which it has been showing it 4 times.

In the log it shows it once, but the Shader Creation it shows 2 times as it is showing in the Substance Painter window.

And note, the last test for this was after I started computer, loaded Substance Painter, and loaded the Cymourai Sample via the file menu samples option, and changed to 4K, so those were the steps. And it resulted in a video driver crash and recovery, then the application stopped responding, and then crashed with the Substance Painter.exe caused crash message.

Nothing else is loaded which would interfere with Substance Painter, and Substance Painter is currently the only application giving this crash.

I notice that the log file says amd is singlethreaded, and it also has this alot:
[ ERR] <Qt> "[DBG ERROR][Url Helpers]" Invalid File URL
[ ERR] <Qt> "[DBG ERROR][Url Helpers]" url:   QUrl( "paint/scene.assbin" )
Last Edit: November 18, 2014, 08:44:52 am

Hi Michael,

When that freeze happens can you please send us the log?

Thanks!
Nicolas

How should I send a log, if my computer freezes? The only thing I can do is press the power button and force a shutdown.

Update: Since I have installed SD 4.5.2 und updated my GPU driver, SD is working fine, but Painer crashes while opening a project.
The only message I get is from my GPU driver "has been disabled..."
Painter doesn´t respond anymore, so I cannot send any log files...

We have similar machines at our office but we didn't manage to reproduce this problem...

I would anyway recommend to use SP 1.0.1 on Mac, as 1.0.2 is really unstable on some Mac. We are investigating on it and working on some fix, but in the meantime we removed 1.0.2 from the website.

Cheers,
Head of Product Management

thanks for the info!

Where can I find SP 1.0.1. for Windows?

Because I am working via bootcamp on win 7

Where can I find SP 1.0.1. for Windows?

Because I am working via bootcamp on win 7

Hi Michael,

When you login to your account, click the "See all Build Versions" link next to the download. This will take you to previous versions you can download.

Substance Painter - 1.0.2 - Build 1.0.2.520 Download - See all build versions

Cheers,

Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

thanks  ::)