Author Topic: Substance plugin 2.2.0 not working right with Corona in 3Ds Max 2020  (Read 4952 times)

I found something really bizarre when I try to change any parameter in a substance file (sbsar) I did with Corona render in 3Ds Max 2020!!!
when I try to change a color for example it changes just perfectly inside materials slot except the final one which is Corona Material, the changes also appear normal inside the view port of Max, but when I render the scene (not using IPR and with IPR) nothing's seems to be changed at all!!!
it remains at the same parameter as when I uploaded that sbsar file?
I will attach some images and they will show that clearly.

what maybe cause that, or is it a bug in Substance Plugin with Corona renderer?
I tried so many times with even manually connected all the inputs and outputs together and nothing's worked!!

any idea?
Thank you.

Same issue if i change a material color, it change on material editor, but not in render  :'(.

I have the same issue,did it worked out in the end?
Sometime if i will play with the parameters a bit it will change.
It's more luck then anything

This bug(?) has been present for Max 2018 and Substance Max plugin since at least Summer 2019, although reports on the forum of this issue precede that period.


Same issue here. The material does not update in my render or material preview render if I change something like base colour of the material.

However, if I change a parameter like the pattern type of a floor material, the base colour updates correctly in the render.

Also, I don't know if this is part of the same issue, but sometimes when making changes to the substance material, the interactive render stops and does not update until I restart it - that makes it more time consuming to make small changes.

Has nobody looked into this?

It's something we're looking at right now to have fixed for the next release.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries


Good to hear, thanks for the update. :)

Will solutions for the Substance for 3ds Max plugin be back-ported to previous versions of 3ds Max, i.e.<2020?

The Substance in 3ds Max plugin is currently released for 2018, 2019 and 2020.

You can find them on our website on the 3ds Max page or linked in the stickied forum post.
Last Edit: February 07, 2020, 08:03:09 pm
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

I'm having the same issue with V-Ray. Updates to the node look correct in viewport but don't update in render.