Author Topic: Substance painter/designer won't run any longer after update - fix please  (Read 39383 times)

I had substance painter and designer running a few days ago and neither run after an update.
I use launcher not steam.  After installing an older version of both it also failed to start.  Running the acual exe file gets the same result.  And the result is that the applications splash screen shows... launcher shows app 'running' then the splash goes away and the launch 'running' button is now 'launch'

How do I fix this?

UPDATE: Posting logs to a pubic site is generally one of the stupidest acts one can take.  However, IT security scrubbed the attached log (well so they said)...   So, log (with same MD5 as sent to security) attach offers NOTHING useful... but, welcome to it.
Last Edit: July 26, 2019, 12:54:53 am

Same here. Can't launch designer via the launcher. (Run as Admin)


Too bad Allegorithmics fails to provide even install support for products.

But, running Launcher as Administrator and then one of the two licenses I cannot use... I get exactly the same results.. a splash screen then nothing.

Sounds to me like they do not want return customers as never being able to use a purchased product will generally have a negative impact on renewal.

Hey guys - have you done a search?'t+launch

Also - support here relies heavily on the log files to help isolate the issue.,22451.0.html
Even if SP won't lauch


Whatever happened to tech support for new installs?   Is this organization reneging after the check clears and does not care that the out of the box experience has now included nearly 30 emails and a few forum posts?

Now, a google search gets a lot of useless information and possibly some useful. I have followed a similar path (google and follow some unknown and unqualified strangers untested instructions).  I only had to replace the motherboard from its being damaged by following such directions once.  So, maybe I can go and do it again and this time and only replace a $3K laptop,

As for logs... you do know that when a real support person actually did the task of support we would likely get asked such questions and given related instructions.   

However, the problem is not related to me/my computer/... it is related to the upgrade as it worked after initial install and then filed the 3rd run after taking the "upgrade".  Why do they need logs to know what they changed which can affect launching?

<-- 45 year software (active) developer for companies you are certain to recognise and likely see each morning on your computer and/or phone...  So, really what is wrong is poor (absent) support atop horrible testing resulting in people thrashing to fill in for their failures. And, since nobody responsible will ask for what could cause this symptom... we have people who are essentially being defrauded as we paid for a product which is intentionally prevented for use.



I sent you a private message for more informations.

Thanks !
QA Analyst


To make progress on the issues written in this thread, we need to get more insights. We are still waiting for input.
If anyone else does have similar issues, please do not hesitate to post it in this thread.