Author Topic: Dots appear when painting on map.  (Read 341 times)

Some of my bakes require i paint over them, well you know how it be sometimes. Anyways, I followed the procedure to set up the normal map in this case to be able to paint on it with a fill layer acting as the normal map base, and a normal for painting. However, as I paint i get these spots that appear over time. Its happened before, but i never figured out WHY its happening and how to stop it from happening.

These normal errors are rather noticeable and i really dont just wanna forego the cleanup, and would be great if anyone that has encountered this before or at least has an idea of how to fix it can chime in.

Can you provide the low and high version and your bake settings so someone can reproduce the problem?

the dots dont appear due to the bake. the dots happen as im painting on it

What brush are you using? Is it happening on a certain channel? Disable each channel and see where the spots are going.

im using the default with sensitivity off and low opacity. also i dont have any other map active, including the original normal map. this seems to be happening on the normal only since i exported the map and re imported and plugged it into the normal map box and they all show there.

Is it possible for you to share the project file which is causing the issue?

Its a rather heavy file, not sure if i can send it through here

Its a rather heavy file, not sure if i can send it through here

If you use Dropbox or Google Drive send me a PM and i'll take a look for you.

ok sent

ok sent

I should have a reply for you within 2 hours.

alright , thanks

I loaded up your project file and used the default brush to paint height detail as per the video below but no issues show on my end. Am I doing everything you've done?

https://www.dropbox.com/s/24rkbt9iqa0cma3/2019-09-18%2019-43-49.mp4?dl=0

If you're doing 100% what I did in this video can you please update your video card and also post your log file as per:

https://docs.substance3d.com/spdoc/exporting-the-log-file-128745475.html

You shouldn't be having normal distortion from just painting as I did in the video.

Hmm i didnt go about it that way. Let me boot up the scene and ill record a video myself and show you how i went about it.

Hmm i didnt go about it that way. Let me boot up the scene and ill record a video myself and show you how i went about it.

Please do because normally when you're painting details that effect the normal map you use 'Height'. Aside from normal stamping of course.

Heres the vid :https://www.dropbox.com/s/xhwdx49lwo0v1y7/where.mp4?dl=0

A bit long (2 min+) but i wanted to show how set it up. Also i followed the documentation for painting the normals which is essentially how i set it up. the documentation never mentioned height to my recollection.