Author Topic: "Failed to import...Failed to create asset" after trying to reimport sbsar UE4  (Read 7213 times)

Dear Substance Gurus,

I've been struggling and googling for the last 2 days looking for a solution to this problem and I can't find anything. I've made an .sbsar and imported it into unreal, no problem, it creates the factory and textures as it should. But after I made some changes back in Substance and tried to reimport it, I either get the error message "Failed to import [file location]. Failed to create asset [unreal project location]" or "Failed to reimport [file name] (SubstanceInstanceFactory)".

I tried changing the .sbsar file name, but it still recognizes the file and gives me the error message. Other .sbsar's work just fine, and importing the problematic .sbsar into other Unreal projects works also, so it must have to do something with the fact that I'm trying to reimport.

I would greatly appreciate an experts opinion on this, as I'm out of clues as to what to try.

Hey guys I dig up this post because I have the same problem here, once I try to import my sbsar in UE4 I have the same error:

"Failed to import 'G:\blablabla/blabla\Decals.sbsar'. Failed to create asset '/Game/Sbsar/Decals'.
Please see Output Log for details."

I though that it was maybe the file directory that was too long and try some other one but nothing is working yet?!
I also tried with an old substance and it worked but still nothing with the new one.
Last Edit: December 13, 2019, 05:44:33 pm
Luca Eliseo
Environment artist looking for a job.

same problem here.. do you need the plugin to even load substance to UE4 Release 4.24?
When I just try to drag and drop the .sbsar file I am getting the same error.

Can someone please take a look at this problem?